Err99- 450D ERROR


velasco

Senior Member
Jul 7, 2006
2,627
0
0
29
PARISris , Singapore
ukellyclarkson.com
#1
Hello all, I am so devastated there's something wrong with my 450D / XSI. Has anyone encountered this problem?

Before the whole Err99 appears, like below:

"ERR 99 Shooting is not possible
Turn the power switch to off and on again or re-install the battery."


IMG_8022 by *iskandar, on Flickr

I had these on my last few shots, as though an aperture blade fell off. So I assumed there is something wrong with my 50mm lens but when I switched to kit lens, the problem still persists.

Now when I turn it on, there is a clicking mechanicsm sound from inside.
I can't do anything, the err99 keeps flashing.

Is the shutter dead?

Best regards.
 

eleveninth

Senior Member
Jan 17, 2006
6,217
2
38
#2
Hello all, I am so devastated there's something wrong with my 450D / XSI. Has anyone encountered this problem?

Before the whole Err99 appears, like below:

"ERR 99 Shooting is not possible
Turn the power switch to off and on again or re-install the battery."


IMG_8022 by *iskandar, on Flickr

I had these on my last few shots, as though an aperture blade fell off. So I assumed there is something wrong with my 50mm lens but when I switched to kit lens, the problem still persists.

Now when I turn it on, there is a clicking mechanicsm sound from inside.
I can't do anything, the err99 keeps flashing.

Is the shutter dead?

Best regards.

your 450D so long already I'm not suprised if it is the shutter.

can't tell like tht best to bring to csc bro
 

daredevil123

Moderator
Staff member
Oct 25, 2005
21,645
63
48
lil red dot
#3
Hello all, I am so devastated there's something wrong with my 450D / XSI. Has anyone encountered this problem?

Before the whole Err99 appears, like below:

"ERR 99 Shooting is not possible
Turn the power switch to off and on again or re-install the battery."


IMG_8022 by *iskandar, on Flickr

I had these on my last few shots, as though an aperture blade fell off. So I assumed there is something wrong with my 50mm lens but when I switched to kit lens, the problem still persists.

Now when I turn it on, there is a clicking mechanicsm sound from inside.
I can't do anything, the err99 keeps flashing.

Is the shutter dead?

Best regards.
Looks like the shutter is gone. The rectangular shape of the shadow points to a shutter blade that came loose. Stop using camera and get the shutter replaced.
 

rhino123

Moderator
Staff member
Sep 1, 2006
5,243
15
38
NA
#4
Or take it as an excuse to upgrade. 7D is not really selling at very high price now... and 5DmkII is also pretty affordable ;)
 

Blur Shadow

Senior Member
Sep 17, 2005
4,886
4
0
#5
I'm betting your shutter is dead. You may consider sending it to Canon Service Center or simply purchase a new camera.

Just for fun, you may wish to just observe your shutter in action to see if you can spot anything unusual with you.
 

eleveninth

Senior Member
Jan 17, 2006
6,217
2
38
#6
i guess its time to replace!! uve put it too good use!
 

SilverPine

Senior Member
Jul 8, 2007
4,539
6
38
Singapore
#7
Err 99 can be lens and/or camera unknown problem, if you have another lens change and test again if same Err 99 happen again, then is the camera problem. After change to a new lens, if no err 99, then you are sure that the problem is the lens. :)
 

dennisc

Senior Member
Oct 24, 2002
2,026
2
38
Freezing Upp Thomson/Mandai!
#8
check the mirror part, mine came off when the prc driver jammed the brakes a couple of times, and it dropped twice I simply slipped it back and it was working again.
 

eleveninth

Senior Member
Jan 17, 2006
6,217
2
38
#9
Err 99 can be lens and/or camera unknown problem, if you have another lens change and test again if same Err 99 happen again, then is the camera problem. After change to a new lens, if no err 99, then you are sure that the problem is the lens. :)
er did u see the photo?
 

avsquare

Senior Member
Jan 26, 2012
3,306
0
0
#10
hmm, shape of the black thing does looked like shutter blades, but I thought shutters are either aligned horizontally or vertically? this one is like diagonally :confused:
 

Rashkae

Senior Member
Nov 28, 2005
19,105
12
0
#11
check the mirror part, mine came off when the prc driver jammed the brakes a couple of times, and it dropped twice I simply slipped it back and it was working again.
Really? Does it matter if it was a PRC driver? Why are you bringing racism into this thread?
 

fatigue

Senior Member
Sep 26, 2005
2,924
14
38
49
Blk138 Bedok North Ave3
forums.clubsnap.org
#13
One of your shutter blades ( there are 2 sets) could be damaged

Here's how a defective shutter looks like. The one on top is a damaged shutter blades.
The 2 sets at the bottom is the new sets



The fix means the whole shutter will be replaced but a cheap fix would be to replace the blades only.
The shutter blades cost U$20 online. (Edit: some will even sell much cheaper but with MOQ)
Plus labor cost, you can roughly estimate how much the total cost to get it fixed.
 

Last edited:

velasco

Senior Member
Jul 7, 2006
2,627
0
0
29
PARISris , Singapore
ukellyclarkson.com
#14
i guess its time to replace!! uve put it too good use!
hehehe thanks for remembering me. I think I have too. I hope I can get a new one. The thing is I'm so broke right now. The camera has to die in the midst of my India trip logistics. :(

Thanks all for the feedback. I think it is 99.9% shutter problem as assessed through your opinions. This guy replied to me. Whoa he has guts to break the gears down.

XSI (450D) shutter failure, error 99 with tear down pics - Canon Digital Photography Forums

Will update you guys come Monday. :)
 

SilverPine

Senior Member
Jul 8, 2007
4,539
6
38
Singapore
#15
er did u see the photo?
If you can see the photo so am I. The checking method is to make sure that both lens and camera are not both in fault. It happen to me when both camera and lens were still in warranty period giving err99, Canon replace a new lens and replace the camera shutter. I could not believed both can be in fault.
 

eleveninth

Senior Member
Jan 17, 2006
6,217
2
38
#16
Hello all, I am so devastated there's something wrong with my 450D / XSI. Has anyone encountered this problem?

Before the whole Err99 appears, like below:

"ERR 99 Shooting is not possible
Turn the power switch to off and on again or re-install the battery."


IMG_8022 by *iskandar, on Flickr

I had these on my last few shots, as though an aperture blade fell off. So I assumed there is something wrong with my 50mm lens but when I switched to kit lens, the problem still persists.

Now when I turn it on, there is a clicking mechanicsm sound from inside.
I can't do anything, the err99 keeps flashing.

Is the shutter dead?

Best regards.
If you can see the photo so am I. The checking method is to make sure that both lens and camera are not both in fault. It happen to me when both camera and lens were still in warranty period giving err99, Canon replace a new lens and replace the camera shutter. I could not believed both can be in fault.
he did check .
 

velasco

Senior Member
Jul 7, 2006
2,627
0
0
29
PARISris , Singapore
ukellyclarkson.com
#17
Called canon on monday quoted 150.

went down this morning, rep said 450 :eek: I was all fixed in getting a new camera using their priveledge purchase but did not. Wanted to wait another day to decide.

called them again after leaving, quoted 180.


Mad confused. Will go down to canon again. If its 180, i think its more worth it to get it fixed. Wasted my time though.
 

eleveninth

Senior Member
Jan 17, 2006
6,217
2
38
#18
Called canon on monday quoted 150.

went down this morning, rep said 450 :eek: I was all fixed in getting a new camera using their priveledge purchase but did not. Wanted to wait another day to decide.

called them again after leaving, quoted 180.

Mad confused. Will go down to canon again. If its 180, i think its more worth it to get it fixed. Wasted my time though.

Get a 7D lol rumours of 7D2 coming out. so those kiasu ppl sure let go cheap soon. just watch the BNS.
 

daredevil123

Moderator
Staff member
Oct 25, 2005
21,645
63
48
lil red dot
#19
Called canon on monday quoted 150.

went down this morning, rep said 450 :eek: I was all fixed in getting a new camera using their priveledge purchase but did not. Wanted to wait another day to decide.

called them again after leaving, quoted 180.


Mad confused. Will go down to canon again. If its 180, i think its more worth it to get it fixed. Wasted my time though.
Why not talk to fatigue?
 

fatigue

Senior Member
Sep 26, 2005
2,924
14
38
49
Blk138 Bedok North Ave3
forums.clubsnap.org
#20
Thanks all for the feedback. I think it is 99.9% shutter problem as assessed through your opinions. This guy replied to me. Whoa he has guts to break the gears down.

XSI (450D) shutter failure, error 99 with tear down pics - Canon Digital Photography Forums
The guy is amazing! I'm not saying I'm an expert or better than this guy but let me share some tips/precaution for those who wanted to DIY. There are some parts that are not necessary or should I say not suppose to dismantle to replace the shutter blades.

* Not suppose to dismantle lens mount- the distance of lens mount to sensor is critical
* Not suppose to dismantle the AF sensor- the location of AF sensor is very precise. A fraction of a millimeter means a lot
* Not necessary to remove battery compartment
* Must keep the sensor properly to prevent dust/dirt on the surface of the AA filter

:)
 

Top Bottom