C5050 problem


Status
Not open for further replies.

mookie

New Member
Aug 19, 2003
170
0
0
36
Sunnypore
Visit site
#1
Does anyone have this problem?

I switched on my C5050 today and to my horror, it could not focus! I tried all modes, and it can only focus in Super-Macro (Auto).

Is it chip spolit? Warantty over already...is it expensive to replace the chip? :cry:

I still use it for Macro shots and u/w shots even after I have got my e-300. So heart-pain... :cry:
 

tao

Senior Member
Jan 7, 2005
3,767
1
38
Beach Road
#5
chii said:
prehaps the motor for the lens is spoilt?

bring it down to oly service centre for a look.
anyone can advise if the Olympus service centre here charge for assessing the problems with your digicam before giving a price quote?

my old C3040Z is giving me some SM card reading problems... the cam wil hang once in a while when it cannot read the card.

I am wondering if I can get them to take a look at it before assessing the 'damage' and quoting the repair cost.

but wouldn't want to pay super high assessment charges since it is such an old camera.
 

chii

New Member
Nov 30, 2004
802
0
0
SG
chiong.smugmug.com
#6
The best would be to give them a Call.
their service centre is @ Valley Point if i remember correctly.
 

chancy

New Member
Dec 16, 2003
556
0
0
Northern Singapore
Visit site
#7
chii said:
The best would be to give them a Call.
their service centre is @ Valley Point if i remember correctly.
Hello Chii & Tao,

Correction, service centre is at Olympus Studio, High Street Centre, close to Funan, just opposite new Parliment House & Supreme Court building. Valley Point is their sales office.

Cheers,
 

leeter

Senior Member
May 1, 2004
1,936
0
36
#8
don't worry too much, C-5050 seems to have this type of problem, i guess it's because it's placed in drybox too long and nv use it. Try switching on again later (place not in drybox). it should work !! hehee, if not, then no idea about it le

chancy seems to know everything about olympus !! next time i got questions will ask you sia ! Guru of Olmypus
 

tao

Senior Member
Jan 7, 2005
3,767
1
38
Beach Road
#9
chancy said:
Hello Chii & Tao,

Correction, service centre is at Olympus Studio, High Street Centre, close to Funan, just opposite new Parliment House & Supreme Court building. Valley Point is their sales office.

Cheers,
chancy, any idea if they will charge for testing/assessing the camera?
 

chancy

New Member
Dec 16, 2003
556
0
0
Northern Singapore
Visit site
#10
tao said:
chancy, any idea if they will charge for testing/assessing the camera?
Hello Tao,

I'm unsure about inspection charges, but a phone call (1800-6596787) might help. Since I've just done that :) ... I'm happy to announce that NO, ZILCH such charges apply if you refuse repair.

Cheers,
 

chancy

New Member
Dec 16, 2003
556
0
0
Northern Singapore
Visit site
#11
leeter said:
don't worry too much, C-5050 seems to have this type of problem, i guess it's because it's placed in drybox too long and nv use it. Try switching on again later (place not in drybox). it should work !! hehee, if not, then no idea about it le

chancy seems to know everything about olympus !! next time i got questions will ask you sia ! Guru of Olmypus
Hello Leeter,

Thank you but, the sum of knowedge in the Oly forum is greater than its parts. I will have to concede any guru / geeky status to many regular & generous contributors here, they genuinely deserve the title more than I do. It's a team effort & one which surely you can play a part too :)

Cheers,
 

leeter

Senior Member
May 1, 2004
1,936
0
36
#12
haha... ya, trying to contribute too, but what i know tool limited....
 

#13
let me add another potential intermitten problem our dear C5050 might give...i placed my cam into the drybox for 4 mths without the batts...upon placing the batts and turning on the cam and placiong into a shooting mode...the LCD seems flicker like a bad TV...viewing the pics in the view mode the flicker stops...seems like it needs to warm up...cos after consistently keeping it on...the flickering stops...at least for my set...
 

tao

Senior Member
Jan 7, 2005
3,767
1
38
Beach Road
#14
chancy said:
Hello Tao,

I'm unsure about inspection charges, but a phone call (1800-6596787) might help. Since I've just done that :) ... I'm happy to announce that NO, ZILCH such charges apply if you refuse repair.

Cheers,
chancy, you are the MAN! :thumbsup:

thanks! think I will send it in tomorrow. anyone knows what is the opening hours of Oly S'pore?
 

Status
Not open for further replies.
Top Bottom