50D pop up flash won't pop


Status
Not open for further replies.

MonkeyMan

New Member
May 10, 2009
16
0
0
#1
Hi all, have a qn. I was fiddlin around with my 50D, havent used the pop up flash before cos i always use external speedlite, so i jst tried it today. Weird thing is, when i set my iso at 400 in M mode and anythin above that, the pop up flash cant pop up. I pressed the button a couple of times it jst refused to pop up. The i set iso to 100 n tested everythin below 400 it pop up when i pressed in pop up flash button.

Tried an auto shot, of cos in auto mode, the pop up flash didnt pop up, instead iso was automatically set to 1600. Tho i dont ever shoot in auto mode, i'd jst wanna know if anyone knows the reason for this? other 50d users pls help.

Does the focal range distant affect the pop up flash ability? didnt try again, but i think i was zoomed at max 200mm.

Appreciate u guys help....thx
 

Dream Merchant

Moderator
Staff member
Jan 11, 2007
9,659
6
38
#2
Likely Nope.

There's a little plastic rod or lever in your hotshoe which detects when a flash is mounted, and locks the built-in flash from popping up.

It's likely blocked, jammed, damaged or broken. It's usually made of plastic (Genius, Canon!) if that's any indication of how fragile it can be. If you know how to, just pop off the top seating plate and check that rod to see if it clears/moves properly.
 

MonkeyMan

New Member
May 10, 2009
16
0
0
#3
Thx dude but it isn't that. The thing is, when i set iso to 400 n above n press the flash pop up button. Nothin happens. When i set iso anythin below 400 n press the flash pop up button, it pops up. Nothin to do with the lockin rod bro.
 

Rashkae

Senior Member
Nov 28, 2005
19,105
12
0
#4
You're in M mode, and your flash is set to auto? So essentially at anything above ISO 400 the resulting exposure is high enough that you don't need flash, so the flash doesn't pop up.
 

Dream Merchant

Moderator
Staff member
Jan 11, 2007
9,659
6
38
#5
Ahh...my bad.

Could it be there's some sort of Auto ISO or 'safety' setting activated which makes the camera override your trying to activate your built-in flash manually? But I thought only lower end cams would have that sort of function? Hmm ... could check your settings. Do you think it might have something with the Auto Light Optimizer?

Sorry I can't be of more help.
 

#6
Hi, when u mean the flash dont pop up do u mean when u press the "pop flash" button or when pressing the shutter button and expecting it to pop up?
I've just tested it myself, in M mode iso more than 400, it does pop up when i press the "pop flash" button located at the side but not when im pressing the shutter. Hope that helps
 

MonkeyMan

New Member
May 10, 2009
16
0
0
#7
Hey guys thx so muc for all the possible situations, last nite i went into my flash settings for in built flash it was ok. Everythin worked. This afternoon, it worked then again same prob. I went into my flash setting again, fantastic, it could not be opened cos it says external flash is attached. Wah lan my speedlite was in my dry cab loh....no external flash was attached n that msg came up....weird....either theres somethin wrong with my camera or i donno.....

Then i went and clear all my customs settings.....it still didnt work.....after a while it did.....sian.....so donno if camera got prob or maybe when i was experimenting i with my speedlite on my camera somethin went cookoo in the camera......

So far its workin fine.......hopefully it stays that way la......
 

Anson

Senior Member
Jul 31, 2006
8,210
7
38
ansonchew.com
www.ansonchew.com
#8
Then i went and clear all my customs settings.....it still didnt work.....after a while it did.....sian.....so donno if camera got prob or maybe when i was experimenting i with my speedlite on my camera somethin went cookoo in the camera......

So far its workin fine.......hopefully it stays that way la......
I had a similar issue once after getting my camera back from CSC. You can check the metal contact at the side of your hotshoe, it should be bending up and not touch the bottom when your flash is not attached. If it is down, try using a toothpick and push it up (be careful not to break anything). Hope it help. :)
 

Status
Not open for further replies.
Top Bottom