Need help! Please! Battery problem


Status
Not open for further replies.
#1
I have a Pentax Optio E40 which I just use for casual photo taking. Every time I put new batteries in, it says "Batteries Depleted" and shuts off again. Now, I know it's supposed to say that and do that when the batteries have gone flat, but this is happening with EVERY SET OF BATTERIES I PUT IN. Can someone help troubleshoot? I've tried looking for a Pentax service center but as of last month they are apparently not operating at Shriro House. :confused:

Help is much appreciated! :)
 

darrrrrrrrrr

Senior Member
Sep 19, 2006
3,209
5
38
30
Singapore
#2
pentax new agent is emjay, shriro quit already. Peninsula plaza 14th floor.
 

airconvent

Senior Member
Apr 12, 2005
4,778
0
36
#3
Could be an internal power supply circuit problem. I have the same problem with a Kodak camera that was in mint condtion but refused to power up. You can bring it to Emjay for servicing but before you do it, did you try different brands of battery or all from the same batch? :)
 

#4
tried every possible battery I could find in my house, I even tried on other cameras (nikon and canon) and the batteries worked fine. So I know it's the camera and not the battery.
 

istDeS

Senior Member
Dec 7, 2005
4,249
10
0
"River end"
#5
You can send to the new Pentax service center.

Emjay Enterprises PL
14-01, Peninsula Plaza
111, North Bridge Road
Mondays-Fridays: 11.00 AM - 6.30 PM
Tel: 63388948.
 

creampuff

Senior Member
Jul 11, 2006
5,116
1
0
Dover
#7
Yeah starting to have that problem with my Optio E40. Battery life seems much shorter recently even with Eneloops. Oh well...
 

istDeS

Senior Member
Dec 7, 2005
4,249
10
0
"River end"
#8
Yeah starting to have that problem with my Optio E40. Battery life seems much shorter recently even with Eneloops. Oh well...
Well, you can always visit the service center. The service guy is no stranger to you.;)
 

airconvent

Senior Member
Apr 12, 2005
4,778
0
36
#9
Well, you can always visit the service center. The service guy is no stranger to you.;)
Do you mean "Kxxxxx" is there now ? Holycow! When I heard from an astro friend that he was let go due to shiriro closure of the division, I sent a PM to Emjay to let them know he is a valued "pentaxian" and that they should consider bringing him on. They replied that they will take it into serious consideration...looks like they meant it! This should be good for everyone! :thumbsup:
 

airconvent

Senior Member
Apr 12, 2005
4,778
0
36
#10
Yeah starting to have that problem with my Optio E40. Battery life seems much shorter recently even with Eneloops. Oh well...
seems this problem affects some camera and not retricted to one brand. A cheap Kodak I bought a few years back also have this problem. It seems some component failure causes the camera to draw high current. Eventually the drain is so high the camera can't even power up properly with a fully charged or new battery.
 

Status
Not open for further replies.
Top Bottom