HELP! "USB Device Not Recognized"


Status
Not open for further replies.

Waffle

New Member
Sep 10, 2003
332
0
0
32
#1
help!

recently, when i plug in my Canon PowerShot A75 into my laptop and my desktop, this message keeps popping up:



Does anyone know why this happens? It's very irritating. And the problem is, i tested the camera on my friends' systems and it works. At first I thought it was only my laptop, but then my desktop also has the same problem now.

help! :cry:
 

tao

Senior Member
Jan 7, 2005
3,767
1
38
Beach Road
#2
try d/l and reinstall your laptop usb drivers.

if not working, may mean your usb port bye bye liao....
 

Waffle

New Member
Sep 10, 2003
332
0
0
32
#3
OH MY GOD I DON'T BELIEVE IT.

i tried all means possible - reinstalling usb drivers, reinstalling camera and twain drivers, and hell, i even bought a card reader for 25 bucks just so i can retrieve my photos from the memory card, and guess what?

i saw that the wire to the card reader's the same as the one to my camera, so i plugged it in and into the system.

you guessed it. voila. it worked.

THE FRIGGIN WIRE WAS THE PROBLEM.

who would have guessed it? i duno whether to laugh or cry now, 25 bucks fly :cry:
 

ndroo

Moderator
Staff member
Nov 22, 2003
8,243
3
0
47
www.fuzzyeyeballs.com
www.fuzzyeyeballs.com
#4
Waffle said:
you guessed it. voila. it worked.

THE FRIGGIN WIRE WAS THE PROBLEM.

who would have guessed it? i duno whether to laugh or cry now, 25 bucks fly :cry:
Can't u just go back to the shop and get the faulty cable replaced, and keep as a spare ... ur 25 bux is saved
 

afbug

Senior Member
Aug 19, 2004
482
0
0
Planet SG™
#6
Waffle said:
OH MY GOD I DON'T BELIEVE IT.

i tried all means possible - reinstalling usb drivers, reinstalling camera and twain drivers, and hell, i even bought a card reader for 25 bucks just so i can retrieve my photos from the memory card, and guess what?

i saw that the wire to the card reader's the same as the one to my camera, so i plugged it in and into the system.

you guessed it. voila. it worked.

THE FRIGGIN WIRE WAS THE PROBLEM.

who would have guessed it? i duno whether to laugh or cry now, 25 bucks fly :cry:
You should be happy mah. Cable problem. At least not your PC or cam's problem. And, your $25 din fly leh, you got a card reader as well. :)
 

yanyewkay

Senior Member
Sep 22, 2004
3,924
0
0
Cons digger.
#7
there was this discussion about cable thickness and quality of USB cables. Maybe can share the specs of your spoilt and working cable?
 

Status
Not open for further replies.
Top Bottom