Dry cabinet hygrometer


Status
Not open for further replies.

tc811

Senior Member
May 20, 2005
541
0
16
#1
Hi, just curious to know a few things. My existing Digi-cabi DB-036 has been set to around 45%. And i just got a new one from CK Tang brand name is VALUE. No matter how i set the internal know, be it from dry to moist, it always remain at 40%. Is the hygrometer working? or is 40% normal?

According to the guys from CK Tang, he mentioned that to try out the cabinet, normally has to set all the way to dry (at 20%). Once it reached that level, it's consider working. Then when i added in my camera and lens, and set the internal knot to around 1 o'clock position, it will slip all the way to 30% - 40%. Is the cabinet working or i need to ask CK Tang to replace it? Any advice? Thanks.:dunno:
 

Jan 14, 2005
1,541
0
0
#2
Hi, just curious to know a few things. My existing Digi-cabi DB-036 has been set to around 45%. And i just got a new one from CK Tang brand name is VALUE. No matter how i set the internal know, be it from dry to moist, it always remain at 40%. Is the hygrometer working? or is 40% normal?

According to the guys from CK Tang, he mentioned that to try out the cabinet, normally has to set all the way to dry (at 20%). Once it reached that level, it's consider working. Then when i added in my camera and lens, and set the internal knot to around 1 o'clock position, it will slip all the way to 30% - 40%. Is the cabinet working or i need to ask CK Tang to replace it? Any advice? Thanks.:dunno:
It might take quite a long while (maybe a day or more) to reach 20%.

To check whether your hygrometer is working, leave the door open and check the humidity. Singapore humidity is using >70%.

When my cabinet is loaded, it can take up to 2 days to reach the set point of 40%.

BC
 

ipin

Senior Member
Nov 21, 2005
5,387
0
0
#3
Or can get another from Homefix to be sure. :)
 

tc811

Senior Member
May 20, 2005
541
0
16
#4
So far the testing show it's ok. But my concern is that leaving RF at 40%, is it alright for camera accessories (lens, camera, etc)? My existing Digi-Cab is at the region 43-48%, but the new one is >40%.

From articles, camera equipment is best at 45%-50%. :dunno:
 

ipin

Senior Member
Nov 21, 2005
5,387
0
0
#5
So far the testing show it's ok. But my concern is that leaving RF at 40%, is it alright for camera accessories (lens, camera, etc)? My existing Digi-Cab is at the region 43-48%, but the new one is >40%.

From articles, camera equipment is best at 45%-50%. :dunno:
Within the 40-50% range is ok. :)
Do note that each hrgrometer has a 5-10% tolerance range.
 

tc811

Senior Member
May 20, 2005
541
0
16
#6
Within the 40-50% range is ok. :)
Do note that each hrgrometer has a 5-10% tolerance range.
Sorry, just to correct some error.

What i meant is that even thou i turn the know towards moist, it still show me between RH 35-40%. This is worrying in view that it may be too dry for the camera. Then i dun understand why leaving for days and setting still cannot stay standard. Even at 1 o'clock position as recommended by the salesperson, or i adjust towards moist (11 o'clock), the RH hygrometer will still show <40%. Is the cabinet spoilt and not working perfectly? Should i ask for replacement?:dunno:
 

Status
Not open for further replies.
Top Bottom