Canon 18mm-55mm lens AF mode not working?!


SABnomnom

New Member
Mar 29, 2011
3
0
0
25
#1
So I have been using my canon 1000D for about close to a year now and recently my kit lens AF mode is not working. Under whatever lighting or even with flash it doesn't work or it takes a long time. Is the lens spoilt or something? Think canon service centre can do something about it? What should I do?
 

Reportage

Senior Member
Nov 24, 2008
5,785
2
0
#2
not all lens can focus quickly in difficult lighting conditions.

should still be under warranty so go to csc to clear any doubts that you may have.
 

SABnomnom

New Member
Mar 29, 2011
3
0
0
25
#3
It's like it doesn't even really work. Doesn't work like usual anymore. ㅠㅠ by any chance is it faulty?
 

Reportage

Senior Member
Nov 24, 2008
5,785
2
0
#4
go csc. they can help verify for you but do give a call in advance.

i take it you have checked both lens and body were on autofocus rather then manual focus.
 

SABnomnom

New Member
Mar 29, 2011
3
0
0
25
#5
Yes it is. I'm like still new into photography :/ let's say the lens is spoilt, and it's under warranty, they will repair it right ?
 

rhino123

Moderator
Staff member
Sep 1, 2006
5,243
15
38
NA
#7
Yes it is. I'm like still new into photography :/ let's say the lens is spoilt, and it's under warranty, they will repair it right ?
Even if it is not in warranty, when you take down to CSC, they will still repair for you... only that you would need to pay. And if it was in warranty, depending on how the lens was damaged, they will repair it for free...
 

Top Bottom