Zenitar Fisheye 16mm with M42 EOS Adapter


Status
Not open for further replies.

EOS500N

New Member
Jul 24, 2003
1,466
0
0
www.pbase.com
#1
faced a problem using this lens on my EOS Elan 7E (aka EOS 30). apparently the SLR's mirror will hit the inside of the lens when the shutter is released.

no such problem when i tried it on my 350D. anyone knows the cause of this? pls help. thanx a million!
 

EOS500N

New Member
Jul 24, 2003
1,466
0
0
www.pbase.com
#3
ipsum34 said:
check out http://photonotes.org/reviews/zenitar-fisheye/

seems like of all eos bodies, only EOS 30 got this problem. in this case, try screwing out the default rear UV filter, which will give extra 1 to 2 mm for mirror to clear.

cheers
wow am i lucky or wat?! only EOS 30??? thanx a lot dude! ;)
 

mfopus

New Member
Oct 14, 2003
74
0
0
Visit site
#4
Supposedly, this is a more of a problem for the Zenitar with M42 mount + M42 to EOS adaptor. Heard that the Zenitar with dedicated EOS mount is better. Is it possible to swap the mount?
 

metalgear

New Member
Aug 11, 2003
783
0
0
Visit site
#5
I have one on the 20D, no "engineering" issues but my infinity focal point - where everthing is sharp - is at the 60mm mark and not at the usual infinity mark. Is this normal ?
 

EOS500N

New Member
Jul 24, 2003
1,466
0
0
www.pbase.com
#6
i have tried it already. Removing the rear filter solves the problem. My EOS 30 mirror no longer hits the lens.
 

denniskee

Senior Member
Oct 26, 2003
5,468
2
0
bukit batok
Visit site
#7
Wormz777 uses zenitar 16mm f2.8 fish-eye on his eos 33 with no problem. Can check with him.

eos 30 & eos 33 are the same body.
 

EOS500N

New Member
Jul 24, 2003
1,466
0
0
www.pbase.com
#8
denniskee said:
Wormz777 uses zenitar 16mm f2.8 fish-eye on his eos 33 with no problem. Can check with him.

eos 30 & eos 33 are the same body.
thanx dude. apparently as long as i dun use a rear filter its fine. ;)
 

Status
Not open for further replies.
Top Bottom