would like to get some SimpleViewer help.... expertise appreciated


Status
Not open for further replies.
#1
i am trying to use this program in my webpage.
i have read some old posts in here but i am trying to tackle a rather wierd problem (which after a few hours of coding and debugging, i gave up and went to sleep)

let me try to explain this clearly...

BACKGROUND
my goal is to have multiple albums that utilizes the script.
i dont want to use the adminviewer because i am trying to build the flash script into my webpage.
as a simple test,
from my main content page, i have 2 links to 2 different albums.

PROBLEM: album A works perfect, album B doesnt load the photos

STRUCTURE:
my root directory contains the index.htm
in the root dir, it contains 2 sub folders, Album A and Album B
in BOTH these subfolder, it contains all the same files needed to run the page and the script EXCEPT for the actual images in the "image" and "thumbs" (obviously duh) and the imageData file

the thing is, when i run my webpage on the local, it WORKS
when i run it on the server, it doest !!!:angry:

when i open the index.htm on the server and click on the link to Album B, it will show the right imageData information (eg title)
so i know that the imageData file is all ok.
but it is not linking showing the photos on the page.
there is some code somewhere that is not right..

could you help me?
 

Geckorian

New Member
Feb 10, 2004
88
0
0
#2
haagen_dazs said:
i am trying to use this program in my webpage.
i have read some old posts in here but i am trying to tackle a rather wierd problem (which after a few hours of coding and debugging, i gave up and went to sleep)

let me try to explain this clearly...

BACKGROUND
my goal is to have multiple albums that utilizes the script.
i dont want to use the adminviewer because i am trying to build the flash script into my webpage.
as a simple test,
from my main content page, i have 2 links to 2 different albums.

PROBLEM: album A works perfect, album B doesnt load the photos

STRUCTURE:
my root directory contains the index.htm
in the root dir, it contains 2 sub folders, Album A and Album B
in BOTH these subfolder, it contains all the same files needed to run the page and the script EXCEPT for the actual images in the "image" and "thumbs" (obviously duh) and the imageData file

the thing is, when i run my webpage on the local, it WORKS
when i run it on the server, it doest !!!:angry:

when i open the index.htm on the server and click on the link to Album B, it will show the right imageData information (eg title)
so i know that the imageData file is all ok.
but it is not linking showing the photos on the page.
there is some code somewhere that is not right..

could you help me?
Check the directory paths? Might be better if you can provide an URL. :)
 

hwchoy

Senior Member
Jul 16, 2003
1,899
0
0
55
Tampines, Singapore.
www.hexazona.com
#3
what I am doing, is to make a folder containing ALL the images, and another containing ALL the thumbnails, yet another folder containing ALL the XML and yet another containing ALL the index file. each of the index and XML file is named differently so that they can be dumped in the same folder. then the webpage points to the correct index file. all the directory paths are thus the same, making it possible

1. to edit based on a template
2. to cross index images (i.e. one image appearing in multiple albums)

is this what you want?
 

#4
hwchoy said:
yet another folder containing ALL the XML and yet another containing ALL the index file. each of the index and XML file is named differently so
i saw you posted about simpleviewer in the older threads.

this is an option i thought of
BUT
how to you have a folder containing all the XML?
if i change the name of the imageData.xml file, it might not be read properly by the .swf file...
if you can explain how this is done, i will perhaps go this route..
but i am wondering what is wrong with my setup.

my setup works PERFECT local but is screwed on remote.
damn
 

hwchoy

Senior Member
Jul 16, 2003
1,899
0
0
55
Tampines, Singapore.
www.hexazona.com
#6
yes. I will get you an example. oh just remember it is a relative path and must have the end "/"

here's an example

imagePath="./CanonGraphers__Khatib_Bongsu_Feb_06/images/" thumbPath="./CanonGraphers__Khatib_Bongsu_Feb_06/thumbs/"
 

Status
Not open for further replies.
Top Bottom