USB not working


Status
Not open for further replies.
Jun 15, 2003
135
0
0
Visit site
#1
Hi,

I had a problem with usb port recently. I couldn't connect to my card reader or usb link to my camera. I tried install usb driver for this but can't solve the problem. My pc is powered by win98SE. Anyone with any suggestions.

Last resort I am going to reformat and upgrade to win XP.

Cheers. :(
 

chriszzz

New Member
Jan 17, 2003
633
0
0
Visit site
#2
leotitude79 said:
Hi,

I had a problem with usb port recently. I couldn't connect to my card reader or usb link to my camera. I tried install usb driver for this but can't solve the problem. My pc is powered by win98SE. Anyone with any suggestions.

Last resort I am going to reformat and upgrade to win XP.

Cheers. :(
If you have at least 512MB of RAM, I would recommend XP anyway, even if you can fix your Win 9x problem. WinXP, or Win2000, is more robust, and manages memory better, IF you have enough memory to run it in the first place. Apparently, Photoshop and their ilk run better on XP/2000 than on 9x too. I'll bite the bullet and upgrade.
 

gtsoh

New Member
Jan 28, 2004
74
0
0
#4
Hi

Many times it is that the power that is supposed to drive yr peripherals via the PC is simply 'not enough'. When this happens, get one of those card reader with a direct connection to your power point. Gone thru this whole process myself. Works for me.

Good Luck
 

jbma

Senior Member
Dec 28, 2003
3,287
0
0
Tampines
#5
I think an upgrade to XP or Win2k would be the way to go.
 

mylau

New Member
Jan 19, 2002
1,019
0
0
33
#6
leotitude79 said:
Hi,

I had a problem with usb port recently. I couldn't connect to my card reader or usb link to my camera. I tried install usb driver for this but can't solve the problem. My pc is powered by win98SE. Anyone with any suggestions.

Last resort I am going to reformat and upgrade to win XP.

Cheers. :(
I think it is the lack of power supply to the usb ports. are u using a usb hub?
 

Jun 15, 2003
135
0
0
Visit site
#7
mylau said:
I think it is the lack of power supply to the usb ports. are u using a usb hub?
I am not using any usb hub. The usb port is direct from my cpu. As in power not enough wise, have try to connect to the rear usb port also cannot work.

Thanks
 

megaweb

Moderator
Staff member
Jan 17, 2002
8,541
1
38
East
megaweb.clubsnap.org
#8
Ensure the following :
1. Your computer USB driver installed properly
2. Your USB card reader driver installed properly
3. Do not use USB hub or install many USB devices.
4. You do not have many multiple USB drivers installed
5. The USB port from the computer is connected properly to the motherboard

BTW, what is the error ? When you plug in the USB cable from the card reader to the computer USB port, does the Windows detect the card reader ?
 

Jun 15, 2003
135
0
0
Visit site
#9
megaweb said:
Ensure the following :
1. Your computer USB driver installed properly
2. Your USB card reader driver installed properly
3. Do not use USB hub or install many USB devices.
4. You do not have many multiple USB drivers installed
5. The USB port from the computer is connected properly to the motherboard

BTW, what is the error ? When you plug in the USB cable from the card reader to the computer USB port, does the Windows detect the card reader ?
Thanks megaweb.

No, my windows did not detect any card reader even my direct link from my camera. I am using 300D. :confused:
 

megaweb

Moderator
Staff member
Jan 17, 2002
8,541
1
38
East
megaweb.clubsnap.org
#10
leotitude79 said:
Thanks megaweb.

No, my windows did not detect any card reader even my direct link from my camera. I am using 300D. :confused:
I see. Is other USB device work well with your computer ?

If same problem, suspect the following:
1. The USB port from the computer is NOT connected properly to the motherboard
2. Your computer motherboard USB driver is NOT installed properly

If no problem with other USB device, suspect the following:
1. Your USB card reader driver is NOT installed properly
2. You have multiple USB card reader drivers installed, remove those are not in used
3. USB cable is faulty
 

Jun 15, 2003
135
0
0
Visit site
#11
megaweb said:
I see. Is other USB device work well with your computer ?

If same problem, suspect the following:
1. The USB port from the computer is NOT connected properly to the motherboard
2. Your computer motherboard USB driver is NOT installed properly

If no problem with other USB device, suspect the following:
1. Your USB card reader driver is NOT installed properly
2. You have multiple USB card reader drivers installed, remove those are not in used
3. USB cable is faulty
I will go and troubleshoot if the usb is not connected properly to the motherboard. I think I haven't check on this. I don't think the other usb device is working.

THanks a lot for the help. :thumbsup:
 

chunkeat

New Member
Oct 16, 2003
218
0
0
Visit site
#12
Can I ask a slightly different question : how do I transfer pics from digicam (say with SD card) to a laptop without USB port ? Thanks.
 

#13
Right now, I don't think that there is PCMCIA adapter for SD card.

You can get a SD-CF adapter and CF-PCMCIA adapter. Think it will work.
However the price of all this things are costly. Especially the SD-CF adapter.
 

chunkeat

New Member
Oct 16, 2003
218
0
0
Visit site
#14
Where can I get the CF-PCMCIA adapter, Sim Lim Square ? How about some sort of SD to serial adapter or USB to PCMCIA adapter :D ?

Thanks.
 

Status
Not open for further replies.