Tamron 18-270mm F/3.5-6.3 Di II VC PZD for Nikon


Feb 18, 2009
22
0
0
53
#1
Hi,

This lens work fine on my Nikon D7000 but not on the V1 w/FT1. I think it was working before I updated the firmware for the FT1. I could not find any firmware update for the Tamron? Anyone knows where I can download the firmware ... strangely not in Tamron's official site? Or is there not such thing as firmware update for Tamron lens?

Appreciate anyone could advise how to get the Tamron lens working on my Nikon V1. Thks!
 

kandinsky

Moderator
Staff member
Apr 26, 2008
3,014
24
38
#2
Going by Nikon's list of compatible lenses, they do not officially support 3rd party lenses.

The recent update for the FT1 might be the reason.

Third party lenses seem even less compatible than before. Note that Nikon says "AF-S lenses" in their update notice. Only Nikon makes AF-S lenses. Nikon has never tested third party lenses with their cameras or accessories, and leaves it to those third parties to ensure compatibility. With the original FT1 firmware, many Sigma lenses didn't work as expected. With the new software, I'm hearing about far more failures of third-party lenses. My recommendation would be that if your third-party lens is working with the current FT1 software that you avoid updating and talk with your lens maker to see if they're checking compatibility.

http://www.sansmirror.com/newsviews/nikon-silently-updates-ft-1.html
 

Feb 18, 2009
22
0
0
53
#3
Thanks! Sigh .. fortunately the Tamron still works on my Nikon D7000 even after the latest update.
 

Top Bottom