Something wrong with my DigiCab?


Status
Not open for further replies.

yehosaphat

Senior Member
Oct 28, 2005
2,703
0
0
North
#1
Hi all, need you advises pls... I have a HD-60 DigiCab and have been using to store my cam stuff. Recently, I realised that the humidity on the analog scale has been hovering at 60+ to 70+ percent when usually it should be between 40-50%!

Nothing has been touched and the readings were the same even if I turned the knob to very low humidity! Door is closed properly and there is a red light in the cab so mean power is ok right?

How how?? :dunno:
 

Nov 3, 2006
332
0
16
#2
Hi all, need you advises pls... I have a HD-60 DigiCab and have been using to store my cam stuff. Recently, I realised that the humidity on the analog scale has been hovering at 60+ to 70+ percent when usually it should be between 40-50%!

Nothing has been touched and the readings were the same even if I turned the knob to very low humidity! Door is closed properly and there is a red light in the cab so mean power is ok right?
Just got mine two weeks ago...you r right, red(for power) and green light shld be on..and humidity level shld stay as set..mine's stable at ard 48%.Any green light, ie from dim to bright when turned?
 

ipin

Senior Member
Nov 21, 2005
5,387
0
0
#3
Put in another hydrometer to confirm the humidity reading.
 

Hobbesyeo

New Member
Feb 16, 2005
990
0
0
Singapore
www.sxc.hu
#4
Hi all, need you advises pls... I have a HD-60 DigiCab and have been using to store my cam stuff. Recently, I realised that the humidity on the analog scale has been hovering at 60+ to 70+ percent when usually it should be between 40-50%!

Nothing has been touched and the readings were the same even if I turned the knob to very low humidity! Door is closed properly and there is a red light in the cab so mean power is ok right?

How how?? :dunno:
Happened once to me as well. Drying unit is prob dead. U'll need to take the unit out to digicab and exchange for a new one.. assuming its still within the warranty period.
:think:
 

yehosaphat

Senior Member
Oct 28, 2005
2,703
0
0
North
#5
Huh... mine got only red light no green light!

Wah so fast spoilt? bought it august last year only....
 

Artosoft

Senior Member
Aug 31, 2005
3,710
0
0
Tanjong Katong
#6
Huh... mine got only red light no green light!

Wah so fast spoilt? bought it august last year only....
Yours is newer version, single red LED.

Don't forget, electronics stuff, you can't be 100% sure it will not fail. But in most cases, it will serve well.

Regards,
Arto.
 

vaxvms

Senior Member
Dec 21, 2005
679
0
16
BEHIND YOU!!!!!!
#7
get a DHC series ,set to huminity need and on power can already, no trial-and-error problem
down side is more expensive
 

Jan 14, 2005
1,541
0
0
#9
Huh... mine got only red light no green light!

Wah so fast spoilt? bought it august last year only....
Leave it untouched for another 24h and see what happens. Make sure there is suffiecient ventilation around the cabi.

BC
 

hjebat87

New Member
Oct 26, 2005
109
0
0
#10
yup if underwarranty contact them ... that the best solutions... i have three model from them .... only one meter light spoil ...humility works fine .... the AD60 almost 3 years ....
 

yehosaphat

Senior Member
Oct 28, 2005
2,703
0
0
North
#11
Wah lau.. suey man. Think gotta call them out liao.

Now i am taking things out one by one to see if humidity changes ;p
 

ipin

Senior Member
Nov 21, 2005
5,387
0
0
#12
Wah lau.. suey man. Think gotta call them out liao.

Now i am taking things out one by one to see if humidity changes ;p
How would taking things out one by one help reduce the humidity? :dunno: Unless one or some of your items are wet. :sweat: :think:
 

yehosaphat

Senior Member
Oct 28, 2005
2,703
0
0
North
#13
How would taking things out one by one help reduce the humidity? :dunno: Unless one or some of your items are wet. :sweat: :think:
Obviously that is something i am trying to find out...
 

ymmij

New Member
Dec 4, 2005
264
0
0
#15
could it be that the unit is spoilt. i encoutered that for my previous unit and the humility just hover around the 60-70% range. i bought another unit since.
 

yehosaphat

Senior Member
Oct 28, 2005
2,703
0
0
North
#17
Guess wat?! My knob is at the Low position turned since last night. Now it is at 50%! So now at least it is within acceptable range liao! Guess wat I took out.. ;p

filters, filter pouch, spare batteries, lens cleaning soln... I am betting the lens cleaning soln is giving the prob! But... it has been in there since day one lei :think:
 

ipin

Senior Member
Nov 21, 2005
5,387
0
0
#18
Guess wat?! My knob is at the Low position turned since last night. Now it is at 50%! So now at least it is within acceptable range liao! Guess wat I took out.. ;p

filters, filter pouch, spare batteries, lens cleaning soln... I am betting the lens cleaning soln is giving the prob! But... it has been in there since day one lei :think:
Glad you isolated the culprit! :thumbsup: :bsmilie:
Maybe your filter pouch has some sweat? :bsmilie:
 

yehosaphat

Senior Member
Oct 28, 2005
2,703
0
0
North
#19
Glad you isolated the culprit! :thumbsup: :bsmilie:
Maybe your filter pouch has some sweat? :bsmilie:
My guess is there is a leak in my lens cleaning soln ;p Do you guys keep it in your dry cab?
 

Status
Not open for further replies.
Top Bottom