Sigma Lenses rubber body


Status
Not open for further replies.

junkai21

New Member
Sep 13, 2006
545
0
0
#1
Hi Bros,

Do you all have an issue with your Sigma Lenses? Im on a 4 year old 18-200 and the focusing and zoom rings have white powdery stuff which is tough to wipe away due to it's rubber texture. It's not fungus and i can confirm it's dirt. Do you all have similar problems? Im not sure if other Siggy lenses use the same rubber or not.

Also to note, do u feel that sigma lenses' body, u can scratch it and it gets very visible white line? :dunno:
 

KY1977

New Member
Jan 3, 2008
947
0
0
#2
I'm guessing it could be sweat residue. I'm also having it on my Canon lenses. The white lines on the body area also on my Sigmas. Dun think can remove. Why you want to scratch it anyway? :sweat:
 

junkai21

New Member
Sep 13, 2006
545
0
0
#4
Thanks bro liveevil, i took my barrel rubber out! woohoo! ****! Behind the rubber is full of greese. Be careful :)
 

Yappy

Senior Member
May 30, 2004
1,326
2
38
#5
What grease? The grease is left by the manufacturer? Is it part of the lens?
 

Last edited:

PrimePhotog

Deregistered
Oct 25, 2007
1,736
0
0
www.flickr.com
#6
Thanks bro liveevil, i took my barrel rubber out! woohoo! ****! Behind the rubber is full of greese. Be careful
Are you sure it is grease? From what I know, camera manufacturers glue the rubber to the barrel. The grease should be inside the barrel, not outside. If I am wrong, please correct me :)
 

Status
Not open for further replies.
Top Bottom