shutter speed problem with Canon 350D


Status
Not open for further replies.
Mar 9, 2006
4
0
0
#1
Hi i'm using a canon eos 350D but i can't seem to lower my shutter speed below 0.3' whenever i use TV or even M modes. I only seem to get fast shutter speeds when i shoot in auto modes.

So far tried everything even resetting to factory settings...any idea?
 

UandMe

New Member
Sep 18, 2005
346
0
0
www.flickriver.com
#2
panicnation said:
Hi i'm using a canon eos 350D but i can't seem to lower my shutter speed below 0.3' whenever i use TV or even M modes. I only seem to get fast shutter speeds when i shoot in auto modes.

So far tried everything even resetting to factory settings...any idea?
not sure but is there any long exposure option in the menu settings?
 

lsisaxon

Senior Member
Nov 29, 2004
11,941
0
0
#3
panicnation said:
Hi i'm using a canon eos 350D but i can't seem to lower my shutter speed below 0.3' whenever i use TV or even M modes. I only seem to get fast shutter speeds when i shoot in auto modes.

So far tried everything even resetting to factory settings...any idea?
Is your flash on?
 

DeSwitch

Senior Member
Oct 28, 2005
3,202
0
0
51
1.45N 103.83E
www.flickr.com
#4
panicnation said:
Hi i'm using a canon eos 350D but i can't seem to lower my shutter speed below 0.3' whenever i use TV or even M modes. I only seem to get fast shutter speeds when i shoot in auto modes.

So far tried everything even resetting to factory settings...any idea?

strange. Are you saying you cannot set to lower shutter speed in Tv or manual mode? I have no problem with my 350D. Just keep turning the "main dail" while in Tv or manual mode. Otherwise think you need to go to Habour Front liao.
 

Status
Not open for further replies.
Top Bottom