Scratch/smudge on sensor?


Jul 19, 2007
841
0
0
#1
Hi, I've recently noticed two things appearing in my photos and i tried to remove it with the arctic butterfly but to no avail. Could it be a smudge? Or worse, a scratch? (from the looks of it on the high pass filter itself)

Here's some pics (and i know the rest of the sensor is quite dirty too haha :))






Any idea how I can get rid of it? I'm leaving for a trip on Sunday and would really love to bring my camera. Please help!

Thanks in advance :D
 

Last edited:

SilverPine

Senior Member
Jul 8, 2007
4,539
6
38
Singapore
#2
If your camera is a DSLR, try to use blower to clean your senser it may be some dusts. :)

.
 

Jul 19, 2007
841
0
0
#3
yep its a DSLR (D200) i used a blower and the arctic butterfly brush but they both dont work
 

spree86

Senior Member
Feb 3, 2009
4,774
0
0
Bishan
www.flickr.com
#4
yep its a DSLR (D200) i used a blower and the arctic butterfly brush but they both dont work
Hmm doesn't look like dust to me. NSC is not open on weekends, since you need it cleaned by Sunday, bring it down to P&G camera or camera hospital tmr and let them clean it for you.
 

#5
Doesnt look like dust...
looks like a spec of oil stain being brushed across the mirror or censor.

Stop whatever you are doing and send it to NSC for cleaning.
Don't aggreviate the situation.

If you need a camera urgently, why not you rent one for the trip?
 

Jul 19, 2007
841
0
0
#6
okay i'm gonna borrow a D50 for the trip ):

will send my D200 into NSC when i get back. thanks for the replies!