regarding Nixvue Vista questions


Status
Not open for further replies.
Jun 16, 2004
15
0
0
#1
hi,
bought a Nixvue Vista, but notice that after fully charging the battery and neber use it but let it remain in the Vista, the 2nd day that I try to Power on it, was astonish that the battery ran Flat ... try charging again and then after afew days , same thing happens... any one experience this or must I remove the battery from the Vista if I neber use for afew days ? thanx
 

Jun 16, 2004
15
0
0
#2
anyway, the problem is due to the Nixvue Vista circuit board is faulty.. went down to Nixvue head office at Loyang (near Pasir Ris) to replace the internal circuit board on the spot ... veri suay, brand new one also got problem. travel from Jurong West all the way to Pasir Ris *sob* :sweat:
 

nickmak

Senior Member
Apr 16, 2004
2,358
0
0
31
London, UK
www.pbase.com
#3
haha... u no... I own the very first Nixvue Vista ever made - the protoype! Its cuz my uncle knows the people there... hehe... no problems with mine so far! Good luck with it!
 

Jun 16, 2004
15
0
0
#4
haha.. yah.. actually feel that I shld get the other version of Nixvue instead of Vista.. Vista is too expensive and there is not really a necessity to look at the photos on the LCD screen,,

nickmak said:
haha... u no... I own the very first Nixvue Vista ever made - the protoype! Its cuz my uncle knows the people there... hehe... no problems with mine so far! Good luck with it!
 

ahsir

New Member
Jun 16, 2004
14
0
0
#6
That shows the importance of local support lor... some of those cheaper version seems hard to resist , but who knows if u r one of those 1 or 2 % who encounter problems right after purchasing.... heard X-drive is one of those that lacks local support.

nickmak said:
haha... u no... I own the very first Nixvue Vista ever made - the protoype! Its cuz my uncle knows the people there... hehe... no problems with mine so far! Good luck with it!
 

Status
Not open for further replies.
Top Bottom