Problems with Sigma 500 Super DG Flash


Status
Not open for further replies.

rainman

New Member
Apr 4, 2004
1,314
0
0
39
In my own world
#1
Hi all,
I have encountered a problem with my flash recently...

The flash just dun fire...but after a while of triggering it will fire 1 or 2 but will incorrect exposure (picture dun out dark)

Another strange thing i encountered is after I took the flash out from my canon unit...the flash dun fire at all even though the test button is being pressed...

btw my 300d unit have been hack to the lastest firmware dunno if it is the cause...but few weeks ago it was perfectly ok as I just bring them to SBG....

Any 1 encountered such problems before?
Mayb I should revert back to the previous firmware...
 

rainman

New Member
Apr 4, 2004
1,314
0
0
39
In my own world
#3
Guess so....luckily still have 6 months warranty?
need to call them before going down?

Btw how to revert back to original firmware before get caught...keke

can some1 email the original firmware to : geeshong@yahoo.com.sg

Thanks!
 

blurblock

Senior Member
May 30, 2003
3,827
0
0
ytphoto.clubsnap.org
#4
rainman said:
Hi all,
I have encountered a problem with my flash recently...

The flash just dun fire...but after a while of triggering it will fire 1 or 2 but will incorrect exposure (picture dun out dark)

Another strange thing i encountered is after I took the flash out from my canon unit...the flash dun fire at all even though the test button is being pressed...

btw my 300d unit have been hack to the lastest firmware dunno if it is the cause...but few weeks ago it was perfectly ok as I just bring them to SBG....

Any 1 encountered such problems before?
Mayb I should revert back to the previous firmware...

Think something wrong with your 500DG Super. You want me to lend you my 500DG Super for testing?

Anyway, you can download the firmware from here :

http://web.canon.jp/Imaging/eosdigital/E3kr_firmware-e.html

Should be quite authentic.
 

rainman

New Member
Apr 4, 2004
1,314
0
0
39
In my own world
#7
blurblock said:
Think something wrong with your 500DG Super. You want me to lend you my 500DG Super for testing?

Anyway, you can download the firmware from here :

http://web.canon.jp/Imaging/eosdigital/E3kr_firmware-e.html

Should be quite authentic.

Thanks...cos mine is just newly bought set...just over 1 month
probably will take it back together with my 300d to MSCOLOR to verify....

One thing I observed...even I do offline test on the flash...the respond seems a bit sluggish... recycle takes ard 9 cycle for another "test flash"
which I thought when the red LED is lit the flash is ready..

Do u have the same problems on ur sigma DG 500 super flash? and yes, my 2100 mah batts are fully charged. :)
 

blurblock

Senior Member
May 30, 2003
3,827
0
0
ytphoto.clubsnap.org
#8
rainman said:
Thanks...cos mine is just newly bought set...just over 1 month
probably will take it back together with my 300d to MSCOLOR to verify....

One thing I observed...even I do offline test on the flash...the respond seems a bit sluggish... recycle takes ard 9 cycle for another "test flash"
which I thought when the red LED is lit the flash is ready..

Do u have the same problems on ur sigma DG 500 super flash? and yes, my 2100 mah batts are fully charged. :)
Nope .... don't think my 500DG has such problem.
 

Ah Pao

Senior Member
Nov 7, 2003
1,662
0
36
Singapore
www.facebook.com
#9
rainman said:
Do u have the same problems on ur sigma DG 500 super flash? and yes, my 2100 mah batts are fully charged. :)
Nope, don't have such a problem with my flash yet. Been using it pretty frequently for the past months and no problems yet.

The reason why I'm suggesting battery problems is to have a complete diagnosis at your end before making a trip down to MS Color...if it turns out that it is indeed your batteries, then it's a waste of time, not to mention you'll feel foolish about yourself.

Again, try with a new set of Alkalines? ;p

But from your description I suspect it may be the flash that's giving the problem, although it doesn't hurt to have a test to completely rule out battery problems.
 

rainman

New Member
Apr 4, 2004
1,314
0
0
39
In my own world
#10
Thks pal...brought down to ms colors last week..and had been confirmed that the flash is faulty...dunno when can they give me back my flash...waited very long liao

anyone have experience on this kind of repairing service...anyway its just less than a month old..wha lau hope they can give me a new set.
 

justdoit

New Member
Sep 29, 2003
150
0
0
40
Locations
#11
I wanted to get one Sigma 500 DG Super also. but there is this guy saying that the flash tends to overexpose when shooting at high ISO and wide aperture. (eg. ISO 400, f/4)
Anyone encountered this before?
 

blurblock

Senior Member
May 30, 2003
3,827
0
0
ytphoto.clubsnap.org
#12
justdoit said:
I wanted to get one Sigma 500 DG Super also. but there is this guy saying that the flash tends to overexpose when shooting at high ISO and wide aperture. (eg. ISO 400, f/4)
Anyone encountered this before?
Nope, never encounter before for both my Canon and my Minolta ...... not too sure about Nikon though.....
 

rainman

New Member
Apr 4, 2004
1,314
0
0
39
In my own world
#13
justdoit said:
I wanted to get one Sigma 500 DG Super also. but there is this guy saying that the flash tends to overexpose when shooting at high ISO and wide aperture. (eg. ISO 400, f/4)
Anyone encountered this before?

get it from blurblock..think he's still selling..grab it before he closes the deal.

Which camera u r using? 300d? In fact even with my 300d built in flash it doesn't gives me consistent flash power esp when shooting high contrast scene. Guess its just the camera metering ability. Do a exposure lock and everything's ok :)
 

Status
Not open for further replies.
Top Bottom