Problems with 8800


Status
Not open for further replies.

Geordie

New Member
Dec 15, 2005
434
0
0
hey all, im a newbie here.

Juz got myself a 2nd hand 8800. It seems to me that the battery is exhausted very quickly for normal usage. When I place a fully charge batt in the cam, leave it overnight in the bag, the next day the batt was dead... needs recharging... anyone has similar experience or was i juz careless in something? :embrass:

Also when the cam is in shooting mode (A S M P Auto), there is a soft high pitch sound coming from the cam.. when switched to other modes, the sound disappears. Does any 8800 owners experience the same thing?
 

funkguru

New Member
Oct 14, 2005
31
0
0
rivervalley
Hi,
The thing with the sound is normal, its the same as mine but I think there's something wrong with your batt. Maybe you should get a spare.
 

bracket

New Member
Dec 5, 2005
13
0
0
Geordie said:
hey all, im a newbie here.

Juz got myself a 2nd hand 8800. It seems to me that the battery is exhausted very quickly for normal usage. When I place a fully charge batt in the cam, leave it overnight in the bag, the next day the batt was dead... needs recharging... anyone has similar experience or was i juz careless in something? :embrass:

Also when the cam is in shooting mode (A S M P Auto), there is a soft high pitch sound coming from the cam.. when switched to other modes, the sound disappears. Does any 8800 owners experience the same thing?
upz for a scary problem.

hope you'll solve it
 

Status
Not open for further replies.