Power Surge on the Hub Port


Status
Not open for further replies.

Trey

New Member
Jun 28, 2005
69
0
0
40
Hard to keep track
#1
Hi guys

Im facing this problem with my FZ-20 recently, everytime when I try to connect
my cam to a pc it always promnt me this

Power Surge on the Hub Port"
A USB device has exceeded the power limits of its hub port.


What seems to be the main problem?

Thanks in advance
 

hercules

New Member
Jul 6, 2005
36
0
0
#2
:Hi Trey ..i also got this problem..if i'm not wrong (i'm not a computer expert)..your PC USB port is a slower verison 1....
:i experience this when i plug in any USB related stuff (like tumbdrives/camera cable/printer)..and my PC doesn't detect it , keep giving this stupid warning message....
:and sometimes never plug in anything also this message will appear...
:my solution to this is ...shut down your PC....plug in your USB stuff(your camera with cable in this scenario...) turn on the camera ....then turn on your PC.....it works for me but dun noe whether works for you or not...??
:another solution...that my fren recommend is to get a faster USB port (i dun noe what this device is called, forgot liao)..but i haven't try yet...
:if anybody else got the proper solution to help us ..pls advise us too...

Regards
 

k3nn3th03

Senior Member
Jan 6, 2005
2,544
0
0
#4
AReality said:
your hub cannot supply enough power to the camera.

Get a hub that has an external power supply.
maybe...

try to get a reader...
 

Status
Not open for further replies.
Top Bottom