Possible issue with camera


Status
Not open for further replies.
Dec 10, 2008
1,732
0
0
26
Pasir Ris
#1
Just realised a few days ago that when I press down on the camera shutter button, the shutter does not fire. No issues with battery grip's shutter button. This occurs roughly once for every fifteen shots I attempt. The shutter just won't fire unless I hold it down for a few seconds or re-press the shutter button to focus. No idea what's wrong with the camera. Anyone know what is going on?

In the likelihood that I need to send my camera to CSC..well I haven't registered my warranty yet. Bought it around 10 months ago. If I register now and bring it down tomorrow, would my camera still be under warranty?

Thanks
 

Aug 15, 2008
74
0
6
SG
#2
I've encountered such problem before a few weeks back. I tried turning off and on the camera, but still the same. But the next day i try, its back to normal again.. No idea what happened.. ><
 

Dream Merchant

Moderator
Staff member
Jan 11, 2007
9,659
6
38
#4
Just register it online and state the correct date you purchased it. :)
 

wkteoh

New Member
Sep 23, 2009
283
0
0
#5
To TS,

Maybe after turning off your camera, hold down your shutter button and twist it in semi-circles several times. That might temporarily solve the problem.
 

henry soh

New Member
Aug 29, 2008
851
0
0
#6
Hi, It could be how the software works with the hardware inside that particluar model of the camera that sets the way the camera works. Anyway, it should be sent back for confirmation as to whether it is faulty. The warranty card that is posted is assumed to be misled through the post in any case.
 

Status
Not open for further replies.
Top Bottom