PC boot up, blank screen, no beep sound.....


Status
Not open for further replies.

Jaycelim

New Member
Jul 15, 2006
249
0
0
Guillemard
#5
The single beep sound mean u have pass POST (Power On Self Test). Various beep sound means different problem.

No beep sound is the worst problem. U have FAILED POST. Likely your processor or the mobo is fried.

Had a similar problem b4, thought it was mobo. Changed and still the same, finally changed processor and sloved the problem.

Quite diff to test, it could the mobo that fried the processor, unless u have a spare old processor that u don't mind get fried.

A quick way to test if it's the RAM problem. Plug out the RAM and boot the system. If still no beep at all, then it's not the RAM problem. RAM problem will give u a few beep sounds depending on the bios.
 

Lenscapes

New Member
Apr 28, 2004
942
0
0
#7
Could be just the power supply..
happened to mine before.. get new PS from SLS
and it is now working happily.:)
 

weicom

New Member
Dec 13, 2005
102
0
0
East
#8
can be a hdd failure too...
it's easier if u got other replacement parts to test
if not juz use this method
unplug the rest of the hardwares except cpu, mobo, psu, vga card and ram (try use only 1 if u got more than 1 ram)
monitor of course keep it on.
if can boot up, means those parts r all ok
then will be your hdd prob.

if not then need to find replacement alr. borrow from fren will be a gd idea as my fren always do tat

gd luck
 

scandisk

Senior Member
Feb 12, 2005
4,618
0
0
Tampines, Singapore
www.facebook.com
#9
phew....now OK....my add-in VGA was the prob (or could be the AGP slot). Will find another PC to test VGA card....for now am running the built in VGA on the mobo....
 

Status
Not open for further replies.
Top Bottom