Olympus OMD EM-5 Problems


mcsucram

New Member
Jul 29, 2012
162
0
0
Singapore
#1
Hi guys, would like to know what has happened to my em5. Just today I was shooting and suddenly many red and some weird colour lines appeared on my lcd screen. Even after awhile, the view finder went totally white that I've to on and off the camera again to continue shooting. If any of you have encountered the same problem as me, please kindly let me know what it is. Thanks
 

Apr 26, 2012
41
0
0
#2
Hi guys, would like to know what has happened to my em5. Just today I was shooting and suddenly many red and some weird colour lines appeared on my lcd screen. Even after awhile, the view finder went totally white that I've to on and off the camera again to continue shooting. If any of you have encountered the same problem as me, please kindly let me know what it is. Thanks
why not send it down to the service center. easier
 

Apr 10, 2008
250
0
16
Balestier, Singapore
#3
are you using an olympus lens . I have an issue with my Panasonic F1.7 . It someimtes freezes the camera when i goes into sleep and I have to take the battery out to restart it.

However I am prepared to put up with this inconvenience because I love the lens .
 

mcsucram

New Member
Jul 29, 2012
162
0
0
Singapore
#5
MeMyselfAndI - Yeah, just sent it to the service center and they told me that I'm the first one who encountered such problem..

Expat yorkshire - Nope I'm using a 100-300 lumix haha anyway that's way too troublesome.

Bryson - That's what I'm doing right now, hope everything's gonna be fine cause I need my camera asap.
 

Last edited:
Top Bottom