Nissin Di866 mk II cannot fire


slmka

Senior Member
Dec 5, 2004
595
0
16
#1
my Nissin Di866 decided to go on holiday just before the CNY >_<

The current status of the flash:
1) Can be powered on.
2) Camera could control the flash
3) Zoom is working
4) Sub flash is working

Problem:
1) Cannot test fire the flash, when I press the "pilot", the AF assist light will blink 2 short, 1 long, together with beep sound

I have tried:
1) Changing batteries (with a set of fully charged)
2) Shut down the flash for whole day
3) Transfer the flash on another camera

Have anyone encountered similar issue before? Thanks
 

slmka

Senior Member
Dec 5, 2004
595
0
16
#4
I just kenna same problem. @#$%&@$$%&*
how about your sub flash?

mine was the main PCB board problem and was charged $60 for the repair (mine is not local warranty)
 

slmka

Senior Member
Dec 5, 2004
595
0
16
#6
it should be...since is not damage by user. But you better call up and check...
 

farbird

New Member
Jan 14, 2004
670
0
0
42
www.farbird.com
#7
sent in already to bendemeer.. they said will take 1 week...

how long did urs take to service?
 

robin-ang

New Member
Sep 11, 2011
354
0
0
sengkang
#8
farbird said:
sent in already to bendemeer.. they said will take 1 week...

how long did urs take to service?
Last time I also facing of this problem then sent back to the shop for warranty waiting for 2weeks but after fix the problem come again then there change a new for me..it was taking more then 2 weeks :(
 

farbird

New Member
Jan 14, 2004
670
0
0
42
www.farbird.com
#9
sian 1/2.

Besides getting the 580ex2, any other alternatives that does ettl2 and easy to use such as the 866mk2?
 

farbird

New Member
Jan 14, 2004
670
0
0
42
www.farbird.com
#10
I recall setting camera to AV and shutter fixed at 1/250 when this happened after a few consecutive flashes before the 866mk2 died on me..

previously was using the flash only for macro at TTL mode with average shutter speed between 1/80-1/160.
 

slmka

Senior Member
Dec 5, 2004
595
0
16
#12
I recall setting camera to AV and shutter fixed at 1/250 when this happened after a few consecutive flashes before the 866mk2 died on me..

previously was using the flash only for macro at TTL mode with average shutter speed between 1/80-1/160.
Mine pretty much the same thing happened. As I was using the sub flash, I did not notice my main flash die until I notice background looks much darker...I was shooting quite happily for the earlier 15mins and show no sign of going down...

If you are not for HSS, may be YN-565 is another optional choice.
 

farbird

New Member
Jan 14, 2004
670
0
0
42
www.farbird.com
#13
so consecutive bursting on shutter speeds > 1/160 is not recommended, esp if TTL dictates that flash power needs to be higher in order to expose the frame correctly?


Mine pretty much the same thing happened. As I was using the sub flash, I did not notice my main flash die until I notice background looks much darker...I was shooting quite happily for the earlier 15mins and show no sign of going down...

If you are not for HSS, may be YN-565 is another optional choice.
 

robin-ang

New Member
Sep 11, 2011
354
0
0
sengkang
#14
Haha guys so I think we should get a original better :)

Even if for canon 430ex I Fren using it last more then 1yrs half no problem also :)?
 

slmka

Senior Member
Dec 5, 2004
595
0
16
#15
so consecutive bursting on shutter speeds > 1/160 is not recommended, esp if TTL dictates that flash power needs to be higher in order to expose the frame correctly?
I can't say yes, the day it dies it was at night...so shutter speed is still below x-sync...

I think only can say both of us are just "lucky"

I want original also, but Nissin is the only one comes with sub-flash and mutli-burst
 

farbird

New Member
Jan 14, 2004
670
0
0
42
www.farbird.com
#16
Poor batch?

My mk1 also had problems ..after several high powered consecutive flashes, the overheat symbol appeared. And subsequently after that, overheated just with <10 normal flashes that had few seconds in between them. Was given a replacement set but the TTL was no longer giving correct exposures.

Hope this time, it will not be the same experience.
 

Top Bottom