Need help: SB600 Won't FIRE whatsoever


Jul 14, 2010
215
0
0
Singapore
#1
Just bought it 2nd handed a while ago, worked perfectly until tonight.
Now it just won't fire even with new batteries (both rechargeable and un-rechargeable)
The LCD and every button still work normally though.

I tried to reset by pressing the Mode + Power button, but it still not firing anymore.


Can anyone tell me what should I do now please :cry::cry::cry:
 

catchlights

Moderator
Staff member
Sep 27, 2004
21,903
46
48
Punggol, Singapore
www.foto-u.com
#2
just send it to Nikon Service Center to diagnose it.

Nikon Singapore Pte Ltd
[Service Centre]
: No. 80 Anson Road, Fuji Xerox Towers, #10-01/02
Singapore 079907

Operating Hours :
Mon, Tue, Fri: 9am - 530pm
Wed and Thu: 9am - 7pm



Hotline
Fax

: 6 5596 363
: 6 5593 669
 

2100

Senior Member
Mar 3, 2004
3,591
0
0
48
#3
You press the Flash/Fire button, you can hear a tick sound, and the flash LED flashes a wee bit? But then no light flash from the flash tube? If so the flash tube pai liao....

These are HID technology. Over a certain usage sure spoil. Like flouroscent, which is low pressure mercury. But actually more like metal halide than low pressure mercury....
 

ZerocoolAstra

Senior Member
Mar 13, 2008
9,522
0
0
rainy Singapore
#4
Just bought it 2nd handed a while ago, worked perfectly until tonight.
Now it just won't fire even with new batteries (both rechargeable and un-rechargeable)
The LCD and every button still work normally though.

I tried to reset by pressing the Mode + Power button, but it still not firing anymore.


Can anyone tell me what should I do now please :cry::cry::cry:
as '2100' suggested, try pressing the test flash button. Does it fire?
If not, follow 'catchlights' suggestion: bring to NSC for diagnosis and probably repair.

hope that helps :)
 

baggiolee

Senior Member
Dec 7, 2006
1,748
0
36
www.facebook.com
#5
Just bought it 2nd handed a while ago, worked perfectly until tonight.
Now it just won't fire even with new batteries (both rechargeable and un-rechargeable)
The LCD and every button still work normally though.

I tried to reset by pressing the Mode + Power button, but it still not firing anymore.


Can anyone tell me what should I do now please :cry::cry::cry:

samething happen to my sb600 last mth. most likely it's the pcb or flash tube. Nikon quote me 180, as i'm out of warranty so no point fixing. sell to fatigue bro instead lol.

hope urs still under warranty.
 

Dec 5, 2007
132
0
16
#6
Yup just as 2100 has mention. The bulb is either burnt (most of the time) or the circuitry is faulty. Yes the bulb is cheap. but the servicing and replacement is around hundred plus...There is a website somewhere where you can replace it...quite delicate at some stage...All the best. :)
 

Jul 14, 2010
215
0
0
Singapore
#7
You press the Flash/Fire button, you can hear a tick sound, and the flash LED flashes a wee bit? But then no light flash from the flash tube? If so the flash tube pai liao....

These are HID technology. Over a certain usage sure spoil. Like flouroscent, which is low pressure mercury. But actually more like metal halide than low pressure mercury....
no it wont flash or sound anything :(
the AF assist infrared even wont work :(


I will bring to NSC and see what do they say :(
 

NikF601

Senior Member
Jul 26, 2010
1,541
0
36
52
CCK
#8
no it wont flash or sound anything :(
the AF assist infrared even wont work :(


I will bring to NSC and see what do they say :(
Good luck, hope just minor repair if needed. pls update to us the outcome.thks
 

fatigue

Senior Member
Sep 26, 2005
2,924
14
38
50
Blk138 Bedok North Ave3
forums.clubsnap.org
#9
no it wont flash or sound anything :(
the AF assist infrared even wont work :(


I will bring to NSC and see what do they say :(
How about the "READY" light? Does it light up?
If this light is ON, there will be no sound since the capacitor is charged up.
Possible problem is a busted tube. (usual cause of busted tube is due accidental drop of flash unit)

If the "READY" light does not turn ON and no sound, possible problem is the charging PCB.
Same as baggiolee's unit.
 

Jul 14, 2010
215
0
0
Singapore
#10
How about the "READY" light? Does it light up?
If this light is ON, there will be no sound since the capacitor is charged up.
Possible problem is a busted tube. (usual cause of busted tube is due accidental drop of flash unit)

If the "READY" light does not turn ON and no sound, possible problem is the charging PCB.
Same as baggiolee's unit.
hmm the flash button light is on, but the Ready light is not :(

Btw when I let the flash idle for a while, it will show BAT on the LCD panel. Which, i believe, indicates that there is some problem with the batteries, however I've tried 3 other kind of AA batteries, all resulted the same :(
 

Last edited:

baggiolee

Senior Member
Dec 7, 2006
1,748
0
36
www.facebook.com
#11
hmm the flash button light is on, but the Ready light is not :(

Btw when I let the flash idle for a while, it will show BAT on the LCD panel. Which, i believe, indicates that there is some problem with the batteries, however I've tried 3 other kind of AA batteries, all resulted the same :(
i'm quite sure they'll charge u the same as mine. unless they double standard...update us if possible. :)

 

fatigue

Senior Member
Sep 26, 2005
2,924
14
38
50
Blk138 Bedok North Ave3
forums.clubsnap.org
#13
samething happen to my sb600 last mth. most likely it's the pcb or flash tube. Nikon quote me 180, as i'm out of warranty so no point fixing. sell to fatigue bro instead lol.

hope urs still under warranty.
I'll be damned :(

Btw how much did you sell urs btw?
Before it gets OT.
I bought the defective SB600 for fun. Hoping to fix them someday.
I already bought 4 defective units since last year
Too busy with other peoples gears that I haven't touch any of my gears yet :bsmilie:
 

Aug 23, 2009
56
0
0
yishun
#14
i have the same problem of not firing usually when it fires off then u will hear a recharge sound but mine when it fires it juz gives me a tick sound. Mine's still under warrnaty so im unsure if they would charge me similar prices.. sigh!! what bad luck but i did not drop or temper the sb600 juz normal usage..
 

Mar 1, 2008
433
0
0
#15
When and where you bought it from?

Return to the seller / shop..

:)
 

fatigue

Senior Member
Sep 26, 2005
2,924
14
38
50
Blk138 Bedok North Ave3
forums.clubsnap.org
#16
i have the same problem of not firing usually when it fires off then u will hear a recharge sound but mine when it fires it juz gives me a tick sound. Mine's still under warrnaty so im unsure if they would charge me similar prices.. sigh!! what bad luck but i did not drop or temper the sb600 juz normal usage..
The problem could be a defective tube.
You don't hear the recharge sound since the capacitor was not discharged.

No need to worry since your flash still got warranty.
Unless there's a sign of breakage on the tube, then the technician will know that the flash has been accidentally dropped.
 

Big Kahuna

Senior Member
Dec 15, 2004
2,126
1
38
Singapore, Singapore, Singapor
#17
Try a fresh set of rechargable battery, might be weak voltage...last time I use some old rechargable battery....and my SB600 became erratic....got a scare but problem resolved when I use Sanyo Eneloop :thumbsup:
 

Jul 14, 2010
215
0
0
Singapore
#18
Just back from the NSC, Nikon quoted me a total of 133$ for it. They will do 6 months warranty on the replaced part though, guess it's a fair one. I will take it back in probably 2 weeks.
 

almighty00

New Member
Aug 23, 2009
56
0
0
yishun
#19
hi i had the same problem in which the sb600 won't fire i brought it down to NSC got it back after one week they didn charge. Only comment on the service slip was flash tube replaced. So finally my sb600 is alive!
 

Jul 14, 2010
215
0
0
Singapore
#20
hi i had the same problem in which the sb600 won't fire i brought it down to NSC got it back after one week they didn charge. Only comment on the service slip was flash tube replaced. So finally my sb600 is alive!
really? but u got warranty right?
they say they will replace the flash tube too. I dont have no warranty watsoever
 

Top Bottom