Metz CT-1&2 and Mecatwin Users...Please Help!

Nov 30, 2010
Picked up an old Mecatwin unit from a second hand shop a long time ago. It worked fine in the shop so I took it home not really knowing about dryfit batteries and stupidly put it in the cupboard. Doh! I went to take it out the other day and the battery (in a CT2 compartment-very similar to the ct 1) obviously doesn't charge at all. After lots of googling I find that the battery is most probably dead and I should order a new one.I could find them on the net and they are very expensive to buy and ship to me, plus I'm only about 80% sure its the battery and don't want to fork out for something I can't try before I commit to the money. SO, I try the local battery shop.

I went down to the shop and we tested the old battery after it's been on charge all night (both the red and green lights didn't go off during that time).It's only holding 1.5V-just as I thought DEAD. We began to look for a new battery but they don't have any dryfits that will fit in the holder and are the right voltage etc. I've seen some people running external dryfit batteries through these packs so we find a battery with the right voltage etc and hook it up to the pack with alligator clips. I wanted to test the charger unit and it shows with the external battery and voltmeter to be working fine-hooray! Then we tested the flash gun out with the whole set up and it worked too-hooray again! The green LED was on the flash and it fired perfectly-with a low recharge time. BUT this whole alligator clip thing seemed a bit dodgy so the guy in the shop suggested that he can solder some leads into the board so the whole setup is a bit more solid. 'Ok' I say and pick it up a few days later...BUT...

I get home and the flashes will not work.AHHHHH!!!! Worked with alligator clips but not solder...weird.The red light onto of the unit is flashing and shows power when the battery is connected but I plug in the flash and nothing-no green led on the back or charging sound. I plug the battery in charge and it only takes less than an hour for the red light to go off, leaving only the green. Still the flash will not work! So I forked out for the mod for nothing!I have a few speculations about what has gone wrong but don't know how to test them....

1. The soldering job into the board is not solid or the mechanic has dislodged something in the unit when doing the soldering-but that said:why can the battery still be charged?
2. Soldering of the leads needed to be directly onto the battery terminals inside the ct2 unit instead of the points he appears to have put in.But same question as above-why do all the lights function?
3. The three pin output to the flash has failed? Does anyone know the correct voltage it should be outputting through these pins?

Anyone who can help with this problem it's REALLY REALLY appreciated as I don't think I'd be able to get it serviced by anyone over here in Aus.


Senior Member
Jul 12, 2008
Why not try searching for a Metz dealer in your area and hope that they can help you out.
Metz no longer produce such models. I am using the Metz60CT4 and it's still fine bought it
way back 1994 brand new. Having the same issue as yours,when charging the dryfit
both red and green light remain on all the time but that's not an issue as long as the
flash fires and the battery indicate that it's fully charge. Bought two new dryfits battery
just in case as they are hard to come by.

Top Bottom