LX3 and its internal flash. Pls advise


Status
Not open for further replies.

extricate

New Member
Sep 15, 2006
51
0
0
#1
Hi,

I have a prob with my LX3. I can't seem to activate the flash mode whenever i press the "flash" button in IA or manual mode. This is inspite of me opening the external flash slot.

Can anyone advise?
 

Aug 7, 2009
1,563
0
0
#3
Disable Burst Mode.

LX3 flash cannot work when Burst Mode is enabled.

The Burst Mode button is the dustbin button.
 

WingZer0

New Member
Jan 4, 2007
38
0
0
#4
There's a sensor to the flash...it it is bright enough it won't fire the flash.
 

night86mare

Deregistered
Aug 25, 2006
25,541
0
0
www.pbase.com
#5
post pictures when the flash failed to fire, then we can know what is wrong, i.e. situation where it doesn't work.

the possibilities are endless..........
 

alba

New Member
Jan 26, 2002
70
0
0
Ang Sua
Visit site
#6
I was in a club and it was dark. The camera was on auto mode and the flash fail to fire despite trying manual, auto or IA....

Plus there was a sign of the "flash off" that could not be removed despite pressing the the flash button and flipping the flash up. :dunno:

Hope I am clear on explanation.

TIA for any replies :lovegrin:
 

Last edited:
May 26, 2009
79
0
6
#7
Could it be on forced off mode? Press the flash manu button and check the setting.
 

chalib

Senior Member
Oct 4, 2007
2,072
0
0
#8
Check your flash and ISO setting. What setting were you using? This could cause the flash being disabled regardless your camera mode
 

Aug 7, 2009
1,563
0
0
#9
its Burst Mode lah.

flash cannot be turn on if Burst Mode is enabled.
 

norby

New Member
Aug 11, 2009
1
0
0
#10
Why don't you do a master reset so that you're 100% sure that it's not a settings issue?
Then set it to iA mode and see what happens.
 

Status
Not open for further replies.
Top Bottom