I truly HATE Adobe Bridge


Status
Not open for further replies.

Deadpoet

Senior Member
Oct 18, 2004
4,619
0
0
#1
Long story short, it sucks BIG time.

The latest problem, when I label a file that is in portrait orientation, the damn program changes the orientation to landscape.

Did not like Lightroom. Maybe Lightroom II is better. Or anything is better than Bridge. It's slow, it's cumbersome, it's non responsive, and it crashes.

Back from my rant, anyone have any solution to my problem : when Bridge automatically changes the orientation of a file from portrait to landscape when I apply a label to the file?

Thanks...
 

hazmee

Senior Member
May 9, 2004
2,937
1
38
37
Sengkang
noorhazmee.com
#2
That is very weird. I don't have that issue with my Vista SP1 + Bridge. Maybe a program re-install might solve the problem?

Yes, I do agree with you Adobe Bridge being painfully slow and a headache to work with (even with my Mac).
 

Deadpoet

Senior Member
Oct 18, 2004
4,619
0
0
#3
That is very weird. I don't have that issue with my Vista SP1 + Bridge. Maybe a program re-install might solve the problem?

Yes, I do agree with you Adobe Bridge being painfully slow and a headache to work with (even with my Mac).
Reinstall is last option.

Maybe I should give Lightroom II a second chance.

Photoshop is first class bar none, but Bridge is a piece of crap, and I have the same opinion on Lightroom.
 

Jun 9, 2005
200
0
0
#5
That's weird. I never had such a problem with my Bridge before. Though I must agree that Bridge is only useful for some purposes. I only use it because of its ability to display .eps & .ai vector files, which I need in my design workflow.
 

#6
hmm...wat u dun like about lightroom ley?

the interface ? Lightroom 2 interface is just about the same as lightroom. But lightroom 2 has added GND and localized adjustment for exposure/saturation etc...

for me lightroom2 has been great for my usage, much much better than bridge...

from interface to sorting renaming to color adjustment its been great...

why not try the trial version for lightroom2...
 

Deadpoet

Senior Member
Oct 18, 2004
4,619
0
0
#7
This is getting more and more frustrating.

The problem with Bridge changing the image orientation when I applied a label now only applies to some files and not all. duh???

Weird. Bridge is truly a piece of CRAP.
 

Deadpoet

Senior Member
Oct 18, 2004
4,619
0
0
#9
Yeap. Very frustrating. Opened a tech support ticket with Adobe. Knowing those morons, probably cannot help. I was looking back at the support history, including this one, 7 tickets in 5 years, they were only able to resolve ONE.
 

Deadpoet

Senior Member
Oct 18, 2004
4,619
0
0
#11
Before I reinstall, one last question/observation. The above mentioned problem, happens only to on folder and it's sub-folders. Wierd.

On another note, I have started to segerated the files into subfolders hoping the response time will imporve (max 100 files a folder) and to my dismay, still slow like a turtle.
 

hazmee

Senior Member
May 9, 2004
2,937
1
38
37
Sengkang
noorhazmee.com
#12
Before I reinstall, one last question/observation. The above mentioned problem, happens only to on folder and it's sub-folders. Wierd.

On another note, I have started to segerated the files into subfolders hoping the response time will imporve (max 100 files a folder) and to my dismay, still slow like a turtle.
Very likely, the system files might be corrupted or could be some missing. If the reinstall doesn't work, try creating a new folder and see if the problem is there.

Adobe Bridge is a turtle.
 

Deadpoet

Senior Member
Oct 18, 2004
4,619
0
0
#13
Tried new folders already. The problems seemed to be all from one specific shoot. One more additional problem, I cannot ammend or append the metadata of the raw file. Wierd. May not be a Bridge problem, but something else. This is disturbing all the same.

That said, BRIDGE STILL SUCKS.
 

Status
Not open for further replies.
Top Bottom