HELP: trouble installing iomega 120GB ext HDD


Status
Not open for further replies.

synapseman

Senior Member
May 6, 2003
2,196
0
0
State of Confusion
www.pbase.com
#1
When I plug in the drive into any USB port (which have been verified working as they've been used with other devices), the following happens:

Window pops up:
"Found New Hardware
Unknown device"

Then,
"Found New Hardware Wizard

Completing the Found New Hardware Wizard

USB

An error occurred during the installation of this device

The installation failed because a function driver was not specified for this device instance."

Any ideas? My Win2k system just refuses to detect its presence.
 

s2s1

New Member
Nov 4, 2002
637
0
0
38
AMK
Visit site
#2
I think u need install its driver for Win2k. Win2k is not as smart as WinXP. :)
 

Ah_Seng

New Member
Apr 8, 2003
1,360
0
0
Land of the woods........
#3
I'm also using win 2k and uses an iomega 80G ext HDD. I just use whatever they provided and no problem leh....:think:
 

user111

Senior Member
Jul 27, 2004
4,702
0
36
#4
win2k needs the drivers

win xp dont need

there is nothing wrong with the drive
 

burger

New Member
Aug 6, 2005
189
0
0
CCK
#5
Ah_Seng said:
I I just use whatever they provided and no problem leh....:think:
i guess you are using winxp
 

synapseman

Senior Member
May 6, 2003
2,196
0
0
State of Confusion
www.pbase.com
#6
Hmm. Thanks guys.

I've tried searching iomega's site, but can't seem to find any drivers for the product. In fact, it says in its documentation that Win2k/XP no need drivers. And all the tech support people seem to tell me is un-plug and re-boot and try another port.

Must go think summore... :think:
 

burger

New Member
Aug 6, 2005
189
0
0
CCK
#7
What should I do if my Iomega USB Hard Drive is not assigned a drive letter or is not detected in Windows 2000?

dunno if this helps


this should also help
 

Status
Not open for further replies.
Top Bottom