Help! shutter goes crazy after inserting battery


kaldori

New Member
Aug 12, 2011
59
0
0
#1
Help guys, my shutter goes into burst mode after inserting the battery, even when the switch was off. Any clue on what could be the issue?
LCD still powers on and can navigate the menu / preview. But if press the shutter button it shows 'camera error' - the shutter still in burst mode all the time until battery is removed.

It's a Nex 5n that have been with me for years... worth repairing? If so, any recommendation?
 

Zeisser

Senior Member
Jul 12, 2008
2,679
12
38
Tampines
www.flickr.com
#2
Help guys, my shutter goes into burst mode after inserting the battery, even when the switch was off. Any clue on what could be the issue?
LCD still powers on and can navigate the menu / preview. But if press the shutter button it shows 'camera error' - the shutter still in burst mode all the time until battery is removed.

It's a Nex 5n that have been with me for years... worth repairing? If so, any recommendation?
Time to look for a new one
 

Octarine

Moderator
Staff member
Jan 3, 2008
12,641
51
48
Pasir Ris
#3
The straight path to Sony Service Center would be one option. Get an assessment there. Sometimes it can be something small that has large scale effects.
Alternatively, our forum's camera whisperer fatigue could have a look. Contact details in his signature.
There are cameras repair shops in Adelphi mall, just drop my there (near City Hall MRT).
 

shierwin

Senior Member
Dec 29, 2008
3,524
10
38
East Coast
#4
Test with another battery. May be just a faulty battery :)
 

Top Bottom