Help.... my Tamron 28-75 F/2.8...


Status
Not open for further replies.
#1
Hi ,

I have a Tamron 28-75 f/2.8. Haven't used it for some time. It was just lying down in my Digicabinet. Recently thought of selling it off. When i went for the deal, i found that if i turn the focal length to around 70-75mm there is a some error on the screen saying some issues with contact ... please clean it ...


Strange thing is that it happens only on that focal range, but once error pops up, i cannot use it until i power cycle my cam. and this issue is only with this lens.... there is no other issue with any lens.


Anybody has idea what's going wrong... it's not in warranty, so no blind suggestions on " go to service center :) "
 

navlem

New Member
Sep 16, 2007
881
0
0
#2
Use a eraser and try erasing the metal contacts on your lens.
 

catchlights

Moderator
Staff member
Sep 27, 2004
21,903
46
48
Punggol, Singapore
www.foto-u.com
#3
borrow another body to confirm the problem, if problem persist, try clearing the lens contact points.

if still have same problem, and you don't want to bring it to service center.....

try put two hands together, pray hard the problem will go away by itself.
 

#5
borrow another body to confirm the problem, if problem persist, try clearing the lens contact points.

if still have same problem, and you don't want to bring it to service center.....

try put two hands together, pray hard the problem will go away by itself.
:(

It's persistent with other bodies..

I think you got me wrong... i just wanted to see if there is any simple solution ( like cleaning the contacts) before going to the service center. it's just because that solution is always there... :)
 

Status
Not open for further replies.
Top Bottom