Focus beep keeps beeping when on half shutter button


DarkFly3r

New Member
Aug 25, 2008
78
0
0
33
#1
My 600D with 18-55mm kit lens sometimes will keep beeping non-stop and the AF motor keeps moving when im on half shutter button. Is it supposed to be like this? Thanks.
 

nedy77

New Member
Jun 21, 2005
999
0
0
#2
Have the lens taken some knocks or shocks recently? If so, the focus ring might be slightly dented, hence focusing problems
 

DarkFly3r

New Member
Aug 25, 2008
78
0
0
33
#3
Nope, the lens is still in mint condition. Only at times when im trying to focus on some things, it will behave like that.
 

nedy77

New Member
Jun 21, 2005
999
0
0
#4
Nope, the lens is still in mint condition. Only at times when im trying to focus on some things, it will behave like that.
Does it only occurs in low light conditions. Or it happens in bright situations too?
 

DarkFly3r

New Member
Aug 25, 2008
78
0
0
33
#5
Does it only occurs in low light conditions. Or it happens in bright situations too?
Im not too sure. At least for now, it behaves like this when im trying to focus in low light. Funny thing is that it keeps beeping non stop until i re-depress the half shutter button.
 

nedy77

New Member
Jun 21, 2005
999
0
0
#6
In low light situations, the autofocus cant find enough contrasting detials to confirm, so it hunts
 

nedy77

New Member
Jun 21, 2005
999
0
0
#7
It it happens also in daylight situations, then it's time to send it to canon service centre to get advise
 

kei1309

Senior Member
Apr 12, 2010
7,312
23
0
Earth
www.facebook.com
#8
Im not too sure. At least for now, it behaves like this when im trying to focus in low light. Funny thing is that it keeps beeping non stop until i re-depress the half shutter button.
use SPOT AF. it'll lock on better.

and if it persists, it just means the camera is unable to focus. this is due to a few reasons:

1) Lack of contrast/pattern to lock the focus on
2) you're closer to the subject than the minimum focus
3) it's TOO DARK. and when it's too dark, the focus will hunt because the AF module can't find anything to focus on except blackness.
 

daredevil123

Moderator
Staff member
Oct 25, 2005
21,644
63
48
lil red dot
#9
My 600D with 18-55mm kit lens sometimes will keep beeping non-stop and the AF motor keeps moving when im on half shutter button. Is it supposed to be like this? Thanks.
Are you on continuous AF mode or on timer mode?
 

DarkFly3r

New Member
Aug 25, 2008
78
0
0
33
#10
In low light situations, the autofocus cant find enough contrasting detials to confirm, so it hunts
I see, which results to constant beeping? This is my first encounter after owning this camera for about 3 months.
 

DarkFly3r

New Member
Aug 25, 2008
78
0
0
33
#11
use SPOT AF. it'll lock on better.

and if it persists, it just means the camera is unable to focus. this is due to a few reasons:

1) Lack of contrast/pattern to lock the focus on
2) you're closer to the subject than the minimum focus
3) it's TOO DARK. and when it's too dark, the focus will hunt because the AF module can't find anything to focus on except blackness.
Thanks for the info. :)
 

Octarine

Moderator
Staff member
Jan 3, 2008
12,488
26
48
Pasir Ris
#14
what DD123 means is whether you're using Single-AF or Continuous-AF. if you're using C-AF, your camera will keep re-focusing when you're doing the half-press.
In this 'continuous focus mode' (Canon term: AI Servo) the camera will not beep upon locking focus, only the focus confirmation / AF points lights up. The beep only occurs in 'One Shot' and 'AI Focus'.
 

DarkFly3r

New Member
Aug 25, 2008
78
0
0
33
#15
In this 'continuous focus mode' (Canon term: AI Servo) the camera will not beep upon locking focus, only the focus confirmation / AF points lights up. The beep only occurs in 'One Shot' and 'AI Focus'.
For my case, it keeps re-focusing and beeping constantly (AF points didnt light up). Im on AI Servo. Is it normal?
 

kei1309

Senior Member
Apr 12, 2010
7,312
23
0
Earth
www.facebook.com
#16
In this 'continuous focus mode' (Canon term: AI Servo) the camera will not beep upon locking focus, only the focus confirmation / AF points lights up. The beep only occurs in 'One Shot' and 'AI Focus'.
For Canon you mean.

i don't shoot with Canon.

and i usually switch off all the AF-Confirm Beeps.

then perhaps it's been narrowed down to focus hunting, since TS has mentioned that it's only in low-light that this issue persists.

@TS, does it happen in good lighting?
 

daredevil123

Moderator
Staff member
Oct 25, 2005
21,644
63
48
lil red dot
#17
For my case, it keeps re-focusing and beeping constantly (AF points didnt light up). Im on AI Servo. Is it normal?
I have no idea since I am not on Canon... maybe some others using canon can shed some light?
 

robin-ang

New Member
Sep 11, 2011
354
0
0
sengkang
#18
AI servo mostly for sport photography....

One shot: is beep once only "is mean a moving subject that u focus if it moving the focus point wont move to"

AI servo: it will not continue beep and your lens focus ring will not stop turn " is because went the thing or human that you focus it was moving then the focus will follow it move, so only will appear this kind of non stop beep sound"
 

Last edited:

Kongfu

New Member
Sep 16, 2011
513
0
0
45
S'pore, Sengkang
#19
For my case, it keeps re-focusing and beeping constantly (AF points didnt light up). Im on AI Servo. Is it normal?
If you're in AI Servo then the re-focusing is correct since it will track moving subject. But there shouldn't be any beep sound or even focus confirmation light when in AI Servo mode.
 

avsquare

Senior Member
Jan 26, 2012
3,306
0
0
#20
I've never encountered this with AF capable lens.

The only time I have this is when I'm using old manual lens. It happens when I was using Nikkor 50mm f/1.4 Pre-AI with EOS adapter with focus confirmation chip. Whenever my focus is achieved, sometimes the focus confirmation light keeps flashing with the confirmation beep. Like "beep beep beep beep" like that, as if signifying that I've firmly locked on the focus.

The constant beeping also happens when I slightly twist the focus ring back and forth when first focus-lock was achieved. It keeps beeping even though I am twisting the focus ring because my DOF was sufficient - even though I shift the focus ring by a little after first focus lock, the subject is still within the the area of focus and thus, the constant beeping because the AF sensor sensed a change in distance but subject still in focus.

Not sure what's wrong in your case. Under AI Servo there isn't any confirmation beep at all. In any case, does your image suffers any issue? Like mis focus most of the time or something? Does this issue happens on single shot modes also?
 

Top Bottom