Flashing F--


Status
Not open for further replies.

stylocool

New Member
Dec 13, 2006
183
0
0
#1
I recently realised whenever i remove my lens hood from my d80 kit, there will be a flashing F-- in the lcd...after reading the manual it seems that the camera is unable to detect the lens. What i did was to unlock and lock the lens again. This happens also when i take the camera out of the bag by holding onto the lens (might not be a good thing to do).

Is this normal? Or should i bring it to NSC for a check...i suspect either the lens or camera contact is loose.
 

Artosoft

Senior Member
Aug 31, 2005
3,710
0
0
Tanjong Katong
#2
I recently realised whenever i remove my lens hood from my d80 kit, there will be a flashing F-- in the lcd...after reading the manual it seems that the camera is unable to detect the lens. What i did was to unlock and lock the lens again. This happens also when i take the camera out of the bag by holding onto the lens (might not be a good thing to do).

Is this normal? Or should i bring it to NSC for a check...i suspect either the lens or camera contact is loose.
It is still under warranty, go visit NSC. It should not like that.

IIRC, the kit lens come with D80 is lens with non-metal bayonet. Is that really bad?

Regards,
Arto.
 

blazer_workz

Senior Member
May 8, 2006
3,118
0
0
ClubSNAP Community
#4
:think: how does removing lens hood create this problem?
I think when he remove the lens hood..the twisting action causes the contacts to disengage..:think: this should not happen..i think ur lens mounting on the body is loose liao..send in to NSC..
 

Artosoft

Senior Member
Aug 31, 2005
3,710
0
0
Tanjong Katong
#5
I think when he remove the lens hood..the twisting action causes the contacts to disengage..:think: this should not happen..i think ur lens mounting on the body is loose liao..send in to NSC..
Or, maybe must check whether lens is mounting properly to body. Is there any 'click' sound when mounting it?

Regards,
Arto.
 

Jan 28, 2007
410
0
16
North of S'pore
#6
Wow... There's cause for worry if there's no CLICK sound when mounting the lens, and TS must be damn HENG he was not holding the lens & the cam dived.

Bro,

think there definitely is something wrong with the Lens/ Mounting, cos I'm also no the D80, and no such problem.

Or, maybe must check whether lens is mounting properly to body. Is there any 'click' sound when mounting it?

Regards,
Arto.
 

Status
Not open for further replies.
Top Bottom