E-500 "Battery Empty" problem


slyboy

New Member
Mar 10, 2010
11
0
0
26
#1
Hey there,

Hope that someone can help me out with my problem.

The problem is this, after charging my Li-ion Battery for about 6 hours, i only manage to get only around 30 mins of photoshooting time.:dunno:

I :dunno: whether is this either the battery problem or is it my DSLR??

If its my DSLR problem, where can i go to service it?

Thanks and hope someone can help me out

PEACE!! :vhappy: :vhappy:
 

Octarine

Moderator
Staff member
Jan 3, 2008
12,518
31
48
Pasir Ris
#2
Locate the brand of your camera .. take Google, key in "[brand] Singapore service center" - read, take the phone and give them a ring, walk in and hand over your camera and battery. No big thing, right?
 

Sep 12, 2009
566
0
0
#3
I assume E500 refers to Oly E500?

Are you shooting in live view?
 

slyboy

New Member
Mar 10, 2010
11
0
0
26
#4
Locate the brand of your camera .. take Google, key in "[brand] Singapore service center" - read, take the phone and give them a ring, walk in and hand over your camera and battery. No big thing, right?
Yeah I tried that but what I need to know is that is it possible to fix it at any of the local camera shops?;)
 

daredevil123

Moderator
Staff member
Oct 25, 2005
21,660
68
48
lil red dot
#7
TS, most probably your battery is dying. Batteries have life span one, and seeing how this camera was launched 5 years ago, I think the battery is dying. Go buy another replacement battery.
 

Octarine

Moderator
Staff member
Jan 3, 2008
12,518
31
48
Pasir Ris
#8
Yeah I tried that but what I need to know is that is it possible to fix it at any of the local camera shops?;)
Some local camera shops could "fix" it by selling you a new 3rd party battery for the price of the original one - if you have no idea what's going on. Going to service center could verify whether it's only the battery. Not sure whether they also sell new batteries. Check the price guides of Olympus for recommended / reputable shops.
Last but no least: there is an Olympus subforum here. Ask the guys for anything Oly specific.
 

spidey89

Moderator
Staff member
Jun 6, 2007
8,156
12
38
South Western Singapore
#9
Some local camera shops could "fix" it by selling you a new 3rd party battery for the price of the original one - if you have no idea what's going on. Going to service center could verify whether it's only the battery. Not sure whether they also sell new batteries. Check the price guides of Olympus for recommended / reputable shops.
Last but no least: there is an Olympus subforum here. Ask the guys for anything Oly specific.
Actually is ask the four thirds sub forum since the E-500 falls under the four thirds standard, anyway, most probably is battery issue, can try loaning another batt, but best bring down to Olympus to check
 

Sep 12, 2009
566
0
0
#10
Dude. E-500 launched in 2005. No such thing as live view in DSLR back then.
!!!!!!!!!!!

Omg, I was blindly typing, I thought TS was referring to the E520, which does have live view!! Super paiseh, my bad.
 

slyboy

New Member
Mar 10, 2010
11
0
0
26
#11
Thanks to all of you :D Fixed it already, Turns out the battery life span almost dying. Now happily Snapping away ;)
 

Top Bottom