Digicabi DB-036 30L spoilt


Status
Not open for further replies.

ccube78

New Member
Jan 6, 2004
85
0
0
#1
hi guys,

I just got a dry cabinet Digicabi DB-036 30L, but it is not working after just 2 days! The LED on the knob no longer showing green light, RH maintained at 80. Had already sent the warranty card to Digihub on the first day.

Anyone sent a digicabi for repair before? Can just detach the dehumidifier to bring to their store? If need to bring the whole cabinet there, it's too troublesome. If ask for on-site servicing, need to charge money. Not sure how much. Cabinet only worth $109...haiz very suay...
 

Dream Merchant

Moderator
Staff member
Jan 11, 2007
9,660
6
38
#2
Hmm...where is the position of the knob? And how long did it remain closed for after you switched it on? Did you open and close the door, or put any moist/wet items inside, and was the door 'sealed' shut properly? Sometimes a strap ot some little bit can get 'jammed' in between the door preventing it from closing properly. Also, did you take out that little white plastic strips? I can't remember if you need to take one out at the drying box area as well. Perhaps you might want to try a new batery for the hygrometer?

I remember when I first got mine, it took like 4 or 5 days before the RH started going down. I had my knob turned to max at 5 o clock, clockwise position ... Also, for some strage reason, the green LED did not light up till the next day leh, but after that, it was perfect operation all the way.

So, if you missed out any part in the first paragraph, and want to give it another try, remember not to put any moist/wet things inside, and make sure the door is closed properly, then give it at least 2-3 days to 'stabalise' before coming to a consclusion. Do NOT open the door during this period.

Sorry, nong nong questions, but just wanting to help see if you do a process of elimination to find out if there's something really wrong with your digicab.
 

ccube78

New Member
Jan 6, 2004
85
0
0
#3
Actually, it was working for the first 2 days. I could get about RH 40% when my knob is at around 12 o'clock. Suddenly on the 3rd day, the LED just went off and the RH starts to go to 80%.

I have tried putting to 5 o'clock (all the way clockwise) for a day already, no effect. Will try for a few more days...but I think it's really spoilt....
 

Dream Merchant

Moderator
Staff member
Jan 11, 2007
9,660
6
38
#4
Try not putting it to max and see what happens. Or crank the knob all the way down, then slowly bring it back up again, but not to the max. If you like, you could do the Russian thing and turn the entire cab upside down and shake it a bit! LOL! OK, just kidding.
 

Six-GHz

New Member
Nov 29, 2006
968
0
0
#5
Is your power socket working?
 

satan_18349

Deregistered
May 6, 2004
1,497
0
0
hell 極樂世&
#6
Anyone sent a digicabi for repair before? Can just detach the dehumidifier to bring to their store? If need to bring the whole cabinet there, it's too troublesome....

Can just detach the dehumidifier alone and bring to their factory at Thomson area, they will replace you with a new one.
 

Oct 15, 2007
112
0
0
#7
hi guys,

I just got a dry cabinet Digicabi DB-036 30L, but it is not working after just 2 days! The LED on the knob no longer showing green light, RH maintained at 80. Had already sent the warranty card to Digihub on the first day.

Anyone sent a digicabi for repair before? Can just detach the dehumidifier to bring to their store? If need to bring the whole cabinet there, it's too troublesome. If ask for on-site servicing, need to charge money. Not sure how much. Cabinet only worth $109...haiz very suay...
It may not be the cabin's fault. I got the simlar problem when I first bought mine too. Fortunately, it was the transformer that connects to the socket that was faulty and the agent just gave me a new power transformer.
 

ccube78

New Member
Jan 6, 2004
85
0
0
#8
Any instruction on how to remove the dehumidifer? Is there a transformer that I need to remove as well?? I tried all methods...it's still not working. Confirmed spoilt...

I was thinking of removing everything that I can find at the back of the cabinet, and bring to the factory.
 

Aug 22, 2007
257
0
0
#9
just wondering, how long ago you bought this cabinet? if i remember correctly a thread a while back, one of the guys said that the digicabi people offered to deliver a new one to his place and do the 1-to-1.
 

Barrios

Senior Member
May 19, 2002
715
0
16
57
Visit site
#10
Any instruction on how to remove the dehumidifer? Is there a transformer that I need to remove as well?? I tried all methods...it's still not working. Confirmed spoilt...

I was thinking of removing everything that I can find at the back of the cabinet, and bring to the factory.
No no no, just look inside your cabinet, you'll see 6 screws - 3 on top the dehumidifying unit and 3 below. Unscrew them and remove the entire dehumidifying unit from the back of the cabinet. Send the faulty unit to their Tagore office and get a replacement. Very simple procedure. :D

Note: The green light will go off once the desired humidity setting is achieved. You get high RH readings when the knob is turned clockwise. Generally, a setting of between 10 & 11 o'clock would give u a reading of between 40% and 50% RH. The green light should not stay lit all the time, perhaps it will when u turn it clockwise to max RH. Hope it helps.
 

ccube78

New Member
Jan 6, 2004
85
0
0
#11
Brought the spoilt dehumidifer to their office and got a replacement. Turns out that the power supply unit is burnt. FYI, their office opens on weekdays normal working hrs, plus saturday 9am-12pm.
 

subwirl

New Member
Mar 20, 2005
129
0
0
South West
#12
Hi i just bought this same set, srt it up and have both the green and red lights up....BUT my RH digital reading shows no display! nothing at all...even after 5 hours. Is this normal?
 

schon

Senior Member
Sep 10, 2005
2,046
0
0
the other side
#13
Hi i just bought this same set, srt it up and have both the green and red lights up....BUT my RH digital reading shows no display! nothing at all...even after 5 hours. Is this normal?
did you remove the white tab near the meter which 'activates' it?
 

yeoster

New Member
Mar 10, 2008
7
0
0
#18
How come this Digicabi brand like very problematic? Was still going to get one myself...
 

swish

New Member
Mar 20, 2006
279
0
0
#19
mine's at the 12 o'clock position and the RH seems to swing wildly from 30 - 60%. i have not opened my cabinet in days. the original unit was defective so i took it back for an exchange. it appears that this one is not working too well either. sigh.
 

redline15

New Member
Jan 12, 2008
65
0
0
49
#20
i'm also facing similiar problems with flucuating readings from 30 to 50%. I thought it will stabilise after 3 weeks but its seems I still need to tweak it. It's now 44% and I've just turn the setting to 10 o-clock.

Just wondering if aircon will affect it since I use the aircon at night.
 

Status
Not open for further replies.
Top Bottom