Digi Cabi dry cabinet AD 120: How to set RH


Status
Not open for further replies.

sanjayc

New Member
Feb 18, 2007
51
0
0
#1
Hi,
I finally got Digi Cabi dry Cabinet AD-120. It has one light and a knob (leftmost setting: green (high) center : blue and right red (lo) ) . I have been turning the knob in different directions and the highest I got after switchin it on and leavin it on is 37%. Currently, I set it to green (leftmost) and it is at 33%

I am trying to get a range of 45 - 55%. Should I open the cabinet and let the Humidity go up and then set it to a specific point and let it stabilize?

I am not sure. I would appreciate any help. Kept it away from windows and heat. Outside humidity is around 70%

Thanks in Advance
 

DeSwitch

Senior Member
Oct 28, 2005
3,202
0
0
51
1.45N 103.83E
www.flickr.com
#2
When your current humidity is at 37%, you hv to open the door to let in some air. When I was adjusting mine, it went down to 27% so I open the door, fan some air in and turn the knob anitclockwise a little. When I close the door, after some time the humidity reads 45%. After a few hours it reads 36%.. so have to repeat the process until you get the right setting.

The humidity will not go up if you dont open the door. You can switch off the power but it will take a long time for the humidity to go up. Dry cabinet only dehumidifies, not humidify.

Hope thats helps.

my other DHC-60L is easier to set.. just set at 45% and thats it. Maintained that way for 2 years plus.
 

sanjayc

New Member
Feb 18, 2007
51
0
0
#3
Thanks. Still having difficulty settin it. opened the door and let the rh go to 64%. turned towards left side (would say somewhere around 8 clock and between 7 o clock). switched on. dropped to 40% and went to 39%. opened door again and let it go to 46%. switched on and turned knob more anti-clockwise.

my dry box seems easier to use
 

sanjayc

New Member
Feb 18, 2007
51
0
0
#4
No matter which setting I use, its dropping below 40%. Could it be that I have a defective set? I opened the door and let RH rise to 64% and then turned the knob anticlockwise towards left.

still having problem
 

Status
Not open for further replies.
Top Bottom