DIGI CABI 30l users pls respond/ /


Status
Not open for further replies.

dawson

New Member
Jun 1, 2007
133
0
0
46
#3
i bought a Digi Cabi 30l. THre is no light anwhere?

is there suppose to be one?

pls help
is it the DB-036?

if so there is a red and green light indicator
inside the cabinet beside those knobs.
 

ryechua

New Member
Mar 4, 2007
103
0
0
Pasir Ris
#8
the "NEW" DB-036 models do "NOT" have the two led (green and red) indicators.
 

ZeroDivine

Senior Member
Sep 5, 2004
2,071
1
0
andritei.zenfolio.com
#9
near the knob should have 2 light indicator for red(above) and green(below).
check by opening the drybox for a while and close it again. See if your hygrometer registers the drop of humidity(testing if the device works).
ps. sorry this is only for older model, as pointed by ryechua :)
 

ZeroDivine

Senior Member
Sep 5, 2004
2,071
1
0
andritei.zenfolio.com
#11
then I suppose you have nothing to worry about.
However, I am surprised that the newer models do not have lights. Thought at least they serve their purpose as an indicator or some fanciful lighting :p
 

Six-GHz

New Member
Nov 29, 2006
968
0
0
#12
yah the device is working fine . reading at 52
If your reading is around the 50 region, then there should be no lights from the LED knob. There is a green/blue/red scale inside, if you turn the knob all the way to red, then the LED will lights up.

For cameras and lenses, the range is about 45-50, so the knob should be pointing around the 12 o'clock. Don't worry, mine's a DB-036 too.
 

zaxh81

Senior Member
Jan 29, 2003
4,339
0
0
Earth
louisleow.blogspot.com
#13
yah the device is working fine . reading at 52
do you happen to get from amk hub too? mine is quite a new batch,no light.
Only when it reach "certain" point then will have green light for awhile,otherwise is no light.
i have problem reading where the point is,so i just shine a torchlight in.
 

estel

New Member
Jul 17, 2006
344
0
0
#14
Six-GHz and zaxh81 were right. The new models don't come with two lights, and the knob light don't seem to turn on inside recommended operating range for cameras.

This question seem to surface every two weeks.
 

noobie

New Member
Jan 29, 2007
313
0
0
#15
For mine, if I set the knob to 12 o' clock position, it'll register 41-43% too powerful, so I turn it to 10 O' clock and see 50%. :)
 

xiaolanku

New Member
May 17, 2005
148
0
0
#17
mine is spoilt after 6 mth of use only..

!@#!$and they want me to remove the dehumidifier myself and bring down to their company to service..

hai..it costs onli $100 per cabinet and so much trouble for it..
 

noobie

New Member
Jan 29, 2007
313
0
0
#18
mine is spoilt after 6 mth of use only..

!@#!$and they want me to remove the dehumidifier myself and bring down to their company to service..

hai..it costs onli $100 per cabinet and so much trouble for it..
Is yours the old or new version?
 

Jun 18, 2007
134
1
18
Tampines
#20
Mine just gotten it recently, no light too. Reading at 53% @ 12 O'clock.
 

Status
Not open for further replies.
Top Bottom