Cost of servicing SIGMA lens?


Status
Not open for further replies.

Feinwerkbau

Deregistered
May 11, 2004
834
0
0
#1
Just paid a visit to Sigma today.

Was told that it would cost me $130 to fix a faulty aprture, change a printed circuit film piece and do 'whatever was necessary' to make the lens work.

The lens was working perfectly fine before, with exception of the 'sticky' aprture.

No compatibality problems, no fungus, mininal dust (heck, I couldn;t see any), no front or back focus issues ...

So what do you guys think about the $130 they are asking for? Is it justified, or am I being taken for a ride?
 

Feinwerkbau

Deregistered
May 11, 2004
834
0
0
#3
I've been terribly busy recently.

In fact, I have been putting this off for hmm...2 months plus now? So first chance I got, I sent it in to Sigma. Felt 'safer' also lah ... but just wondering how much someone else might have paid for a similar servicing job.
 

smallaperture

Senior Member
Jan 5, 2004
2,441
0
0
Catchment Area
#4
I guess it might be just some cleaning and a bit of lube would solve the problem. BTW, how old is your lens and is it dusty? Jam aperture could be either due to dust or the lube dried up. I understand that some good lenses have got their mechanism "perpetually lubricated" - whatever that means. I heard that there is some lube that could work permanently, without drying out or wear out - teflon or moly.....
 

Feinwerkbau

Deregistered
May 11, 2004
834
0
0
#5
The lens is really clean, and has always been kept in a drybox when not in use.

For all purposes and intent, it was performing flawlessly with exception of the apeture.

I just wonder if I missed something.
 

Status
Not open for further replies.
Top Bottom