Compact Drive help


Status
Not open for further replies.
Feb 22, 2002
431
0
16
31
singapore
Visit site
#1
erm... i just got a compact drive today... formatted it already. but when turn on using battery power, the thing just show a red LED on the status
and the harddisk symbol keeps flashing...

anyone knows whats wrong?

the unit is normal when using power
 

Feb 22, 2002
431
0
16
31
singapore
Visit site
#4
i think batt weak.... or still something wrong cos when change to engerizer e2
now can liao
was using sanyo 2500
 

drumma

Senior Member
Jan 5, 2005
6,299
0
36
30
Oulu, Finland, Finland
www.wongliji.com
#5
i believe it's the sanyo 2500 batts that's causing the errors. even though it showed full bar on my PD70x, it gives me a frowning face when i tried to do file transfer. using 2300mHa(or other batts) or power supply will solve the problem.
 

zaxh81

Senior Member
Jan 29, 2003
4,339
0
0
Earth
louisleow.blogspot.com
#6
Error 20 is low batt,happens when use with the supplied 2500mah from eastgear.
Think it's the battery discharge problem.
 

frisky

Deregistered
Oct 13, 2002
733
0
0
Kitten's Den
Visit site
#7
Don't use the unit to charge batteries. I keep having problems until I use my maha charger to charge those 2500 batteries.
 

telefax

New Member
Jul 6, 2005
54
0
0
#8
frisky said:
Don't use the unit to charge batteries. I keep having problems until I use my maha charger to charge those 2500 batteries.
But EG told me I can use the unit to charge batteries. However, the battery seems to discharge super fast after charging it overnight in unit.

FYI, they gave me the 2300 free when I first bought it.

So you think batt prob??
 

Status
Not open for further replies.
Top Bottom