Canon10D hang!


Status
Not open for further replies.

i_r_i_a

New Member
Jan 28, 2002
83
0
0
Singapore
Had anyone encounter in situation where all Canon10D function was disabled? Did happened once last month when I used with Canon 70-200L IS. I could not adjust shutter speed or aperture and the shutter button wasn't working. I powered off and on, also the same thing. Fortunately I had another sigma lens. I switch and it was back to normal. Then I switched back to the canon lens, it worked normally.
 

andi1704

New Member
Oct 10, 2003
543
0
0
48
i_r_i_a said:
Had anyone encounter in situation where all Canon10D function was disabled? Did happened once last month when I used with Canon 70-200L IS. I could not adjust shutter speed or aperture and the shutter button wasn't working. I powered off and on, also the same thing. Fortunately I had another sigma lens. I switch and it was back to normal. Then I switched back to the canon lens, it worked normally.
it hapens to me as well, basically just the connection of the lens and the camera body, because the lens is so heavy, which one hand holding the camera and the other hold the lens and i assume you shoot between lanscape and potrait is it? , i thing its ok, just switch off for few second, tighten the lens and camera mount and turn on again.
 

Keltzar

Senior Member
Jul 18, 2002
3,353
1
38
West
Visit site
I haven't had that problem, but frankly, considering what the camera/lens combo is worth.... any form of a hang is not acceptable. This is probably a $5,000+ set-up ... not a $250 budget camera.

Personelly, I think canon's QC has just declined over the last 10yrs. The number of camera-related problems seem to be on the rise. Or else they're a victim of their own success... selling more than their QC can cope with.
 

Canonised

Senior Member
Aug 27, 2003
2,989
4
38
Keltzar said:
I haven't had that problem, but frankly, considering what the camera/lens combo is worth.... any form of a hang is not acceptable. This is probably a $5,000+ set-up ... not a $250 budget camera.

Personelly, I think canon's QC has just declined over the last 10yrs. The number of camera-related problems seem to be on the rise. Or else they're a victim of their own success... selling more than their QC can cope with.
Haha,.... have you heard of a million-dollar computer system failing at a crucial moment? or a billion-dollar rocket misfire? What's this $5k thingy ... :haha:
Frankly, i don't think it's the cam's fault, it's probably human error .... my encounters were because i didn't push the CF card in properly.
 

andi1704

New Member
Oct 10, 2003
543
0
0
48
hahaha.....:):):)
 

Status
Not open for further replies.