camera kept blinking FULL cant take anymore pictures!


Oct 5, 2009
172
0
16
Dhoby Ghuat
#1
Hi everyone, my camera was quite unusual today, memory card have space, but it showed the balance at 40 shots even after i deleted some files..and now it left with 0 and it kept blinking FULL on my display, cant take any pictures anymore.. does anybody encountered this be4? or its just tt my shutter count is dead :bsmilie:
 

Rashkae

Senior Member
Nov 28, 2005
19,105
12
0
#2
Best to copy all your pics to PC and try formatting the card in-camera.
 

Irvine

Senior Member
Jan 1, 2010
1,037
0
36
North? South? East? West?
#4
i believe it's more of the memory card's problem. do u haf another memory card to test if it's really the card's problem?
 

Rashkae

Senior Member
Nov 28, 2005
19,105
12
0
#5
i believe it's more of the memory card's problem. do u haf another memory card to test if it's really the card's problem?
Yup, sounds like your card is faulty.
 

daredevil123

Moderator
Staff member
Oct 25, 2005
21,657
68
48
lil red dot
#6
Hi everyone, my camera was quite unusual today, memory card have space, but it showed the balance at 40 shots even after i deleted some files..and now it left with 0 and it kept blinking FULL on my display, cant take any pictures anymore.. does anybody encountered this be4? or its just tt my shutter count is dead :bsmilie:
If your shutter fails, it is a mechanical failure, and the shutter will either jam or not open fully.

There is no shutter count fail such as you described. What you described sounds more like a dead card. Use another card and see if the problem still persist.
 

ZerocoolAstra

Senior Member
Mar 13, 2008
9,522
0
0
rainy Singapore
#7
Hi everyone, my camera was quite unusual today, memory card have space, but it showed the balance at 40 shots even after i deleted some files..and now it left with 0 and it kept blinking FULL on my display, cant take any pictures anymore.. does anybody encountered this be4? or its just tt my shutter count is dead :bsmilie:
That's a very interesting conclusion you have come to! ;)
I wonder what it was based on.
 

Oct 5, 2009
172
0
16
Dhoby Ghuat
#8
i believe it's more of the memory card's problem. do u haf another memory card to test if it's really the card's problem?
Hi Irvine! I've tried a few other cards as well, and its still the same for that moment.. the funny thing was i went to the Dust off ref photo in the setup menu to take a photo, and after a photo was taken, it went back to normal:bsmilie: anyway, thanks alot!
 

Oct 5, 2009
172
0
16
Dhoby Ghuat
#9
i believe it's more of the memory card's problem. do u haf another memory card to test if it's really the card's problem?
Yup, sounds like your card is faulty.
Hi Rashkae, yeah i still cant figure out what exactly happened, meanwhile i also tried cards that belongs to my friend, nothing helps but now it was recovered! but thanks, i will try to observe again!!
 

Top Bottom