anyone with erratic selection wheel?


Status
Not open for further replies.

caterham7

New Member
May 10, 2005
71
0
0
#1
hi all,

have noticed recently that the selection wheel (i.e. the one that changes shutter speed or aperture) on my K100D has been a bit erratic, reducing my aperture when i turn it one direction or the other, instead of increasing in one direction and reducing in the other.

anyone else have the same problem? any solutions besides sending it in to the service centre? don't really want to lose use of the camera at the moment...
 

fengwei

Moderator
Staff member
Aug 25, 2004
14,462
12
0
Queenstown
www.pbase.com
#2
hi all,

have noticed recently that the selection wheel (i.e. the one that changes shutter speed or aperture) on my K100D has been a bit erratic, reducing my aperture when i turn it one direction or the other, instead of increasing in one direction and reducing in the other.

anyone else have the same problem? any solutions besides sending it in to the service centre? don't really want to lose use of the camera at the moment...
Hmm, didn't expect this problem happens on a K100D so soon :confused: This happened on quite a number of Ds cameras as reported before. It's due to the dust/dirt under the wheel (like some wheeled-mouse for PC). Just open it up and clean under the wheel, this would fix the problem :)

Hope your camera is still under warranty, so Shriro would fix it for you for free. Otherwise you'd expect to pay up to $100SGD for the service, unless you have the gut and tools to open it up by yourself ;)

Good luck.
 

istDeS

Senior Member
Dec 7, 2005
4,249
10
0
"River end"
#3
Have not encounter the problem so far on my DS.:) I think it is best to send the camera to the service center to have the wheel fixed.;)
 

Status
Not open for further replies.
Top Bottom