12-60 stuck aperture


schon

Senior Member
Sep 10, 2005
2,046
0
36
the other side
dear all

has anyone faced problems with their 12-60 aperture being stuck at f22 regardless of setting input from the camera?

this means that even if the aperture value is set to 2.8, the physical aperture in the lens remains stopped down, and the viewfinder is dim.

i did a quick search online and found that this is a frequent problem with this lens:

http://forums.dpreview.com/forums/read.asp?forum=1022&message=35979295
http://forums.dpreview.com/forums/read.asp?forum=1022&message=34859902
http://forums.dpreview.com/forums/read.asp?forum=1022&message=34864618
http://forums.dpreview.com/forums/read.asp?forum=1022&message=37048226

i find it puzzling because since this seems to be a design/technical flaw rather than actual damage due to mishandling.

kindly share your experience(s) please.

thank you.
 

spidey89

Moderator
Staff member
Jun 6, 2007
8,166
12
38
South Western Singapore
dear all

has anyone faced problems with their 12-60 aperture being stuck at f22 regardless of setting input from the camera?

this means that even if the aperture value is set to 2.8, the physical aperture in the lens remains stopped down, and the viewfinder is dim.

i did a quick search online and found that this is a frequent problem with this lens:

http://forums.dpreview.com/forums/read.asp?forum=1022&message=35979295
http://forums.dpreview.com/forums/read.asp?forum=1022&message=34859902
http://forums.dpreview.com/forums/read.asp?forum=1022&message=34864618
http://forums.dpreview.com/forums/read.asp?forum=1022&message=37048226

i find it puzzling because since this seems to be a design/technical flaw rather than actual damage due to mishandling.

kindly share your experience(s) please.

thank you.
Bro,so late then post? ahahah, I think Nissinmanic got the same problem, was it you Nissinmanic (If you're reading and I got your nick right :S)
 

egnaro

Senior Member
Dec 19, 2007
2,984
0
36
Boon Lay, Singapore
I think this is a common problem for 12-60.

It happen to me before when I was using Olympus but I was stuck on F16.

I got a friend also have the same problem on his 12-60 (1st AF Motor issue then Aperture stuck), replaced and happen again on a brand new replacement lens.

Think Olympus are well aware of this problem, so send your to them, I think they will change your aperture assembly.
 

spidey89

Moderator
Staff member
Jun 6, 2007
8,166
12
38
South Western Singapore
I think this is a common problem for 12-60.

It happen to me before when I was using Olympus but I was stuck on F16.

I got a friend also have the same problem on his 12-60 (1st AF Motor issue then Aperture stuck), replaced and happen again on a brand new replacement lens.

Think Olympus are well aware of this problem, so send your to them, I think they will change your aperture assembly.
Need to pay?
 

cater

New Member
Apr 12, 2007
433
0
0
I remember 2 cases of such happen to my friend. 1 happen on 50mm and the other is 12-60mm.
 

egnaro

Senior Member
Dec 19, 2007
2,984
0
36
Boon Lay, Singapore
I remember 2 cases of such happen to my friend. 1 happen on 50mm and the other is 12-60mm.
Bro 1 case is me issit???

Bro, very very long didnt call u! I think I need to call u soon... Batam!
 

cater

New Member
Apr 12, 2007
433
0
0
egnaro said:
Bro 1 case is me issit???

Bro, very very long didnt call u! I think I need to call u soon... Batam!
Urs got stuck too? I didn't know abt it.
 

nissanmanic

New Member
Mar 13, 2010
522
0
0
Singapore (Ulu Pandan)
haha. i heard i'm being summoned here.

yes. the aperture of my 12-60mm remained stuck wide open at focal lengths >18mm. when you use the DOF preview and stop down the lens at 12mm (it does activate at FLs <18mm) and zoom in to >18mm, the aperture remains stuck at its stopped down position. You could do what I did then, if you have a spare body (or somebody has) to mount the 12-60mm, try and determine whether it's the lens/body fault by elimination. But your problem sounds awfully similar to mine.

For me I took it down to OSC. took them 2 months to repair, they blamed it on the aperture mechanism which had to be ordered because they didn't have spares. Total damage from this unfortunate episode was close to $280+/-, majority of the charge was due to the $150 labour charge. =/ but it beats having a very expensive paper weight. just thought i'll share with you. Good luck! =)
 

Last edited: