Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Thread: Help! what is this small white cross doing on my photos!

  1. #1

    Default Help! what is this small white cross doing on my photos!

    I zoomed in to check for detail and suddenly i see this! can someone help?


  2. #2

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by Felixbunny View Post
    I zoomed in to check for detail and suddenly i see this! can someone help?

    on your camera or on your computer?

  3. #3

    Default Re: Help! what is this small white cross doing on my photos!

    um both. i on LCD zoom 10X then i see this white cross of doom. haha.

  4. #4

    Default Re: Help! what is this small white cross doing on my photos!

    Dead pixels?

  5. #5

    Default Re: Help! what is this small white cross doing on my photos!

    dead pixels on the sensor

    time to replace it

  6. #6

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by kei1309 View Post
    dead pixels on the sensor

    time to replace it
    ???? replace what? sensor? camera? haha. my camera still under warranty

  7. #7

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by Felixbunny View Post
    ???? replace what? sensor? camera? haha. my camera still under warranty
    is this problem inherent in all your images or just this one?

    if it's a nikon, NSC. if it's a canon, CSC. if it's a sony, sony care. if it's any other brand i don't know anymore

    ask them to check it out, if the problem is in every photo

  8. #8

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by kei1309 View Post
    is this problem inherent in all your images or just this one?

    if it's a nikon, NSC. if it's a canon, CSC. if it's a sony, sony care. if it's any other brand i don't know anymore

    ask them to check it out, if the problem is in every photo
    Its in more than one photo, more than one batch of photos. Lols. seems like i will need to pay a visit to csc before my warranty ends. hahah.. thanks alot bro.

  9. #9

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by Felixbunny View Post
    Its in more than one photo, more than one batch of photos. Lols. seems like i will need to pay a visit to csc before my warranty ends. hahah.. thanks alot bro.
    i'm a girl

  10. #10
    Member crystal1993's Avatar
    Join Date
    Aug 2010
    Location
    Japan, Tokyo
    Posts
    1,049

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by kei1309 View Post
    i'm a girl

  11. #11

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by kei1309 View Post
    i'm a girl
    Lols! paiseh. hahaha.

  12. #12

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by kei1309 View Post
    i'm a girl

  13. #13
    Senior Member luckyorange's Avatar
    Join Date
    Jan 2011
    Location
    Ang Mo Kio
    Posts
    2,843
    Blog Entries
    1

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by kei1309 View Post
    i'm a girl
    Lousy de My Flickr

  14. #14
    Senior Member ZerocoolAstra's Avatar
    Join Date
    Mar 2008
    Location
    rainy Singapore
    Posts
    9,522

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by kei1309 View Post
    i'm a girl

    bluff who?...





    TS, could be defective photosite on your sensor. Not sure if that's considered hotspot or not.
    The service centre should be your best bet for help.

    good luck.
    Do keep us updated on the outcome.

  15. #15
    Moderator
    Join Date
    Nov 2010
    Location
    Somewhere
    Posts
    3,444

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by kei1309 View Post
    i'm a girl
    "I don't know what to say!"
    Too many great equipments but too little quality photos. [My Flickr] | [My Blog]

  16. #16

    Default Re: Help! what is this small white cross doing on my photos!

    Quote Originally Posted by kei1309 View Post
    i'm a girl
    HAHA! The series of emoticons popping up after seeing this is HILARIOUS!
    <EOS 60D> <Sigma 30mm f/1.4> <50mm f/1.8 II>
    <18-55mm f/3.5-5.6 IS> <YongNuo 565EX> <YongNuo 560>

  17. #17
    Senior Member edutilos-'s Avatar
    Join Date
    Dec 2010
    Location
    The Universe
    Posts
    5,991

    Default Re: Help! what is this small white cross doing on my photos!

    It's a STUCK PIXEL.

    http://www.fredmiranda.com/forum/topic/823731

    Need to bring to Canon for pixel mapping, too bad they don't build it into your camera (which is easy to do so) like some other brands do.

    The FM thread says that they can disappear sometimes if you run the sensor cleaning cycle for 1 minute, no harm trying if you want to save yourself a trip.

    There are also other suggestions, like turning on long exposure noise reduction, etc. Read that link.

  18. #18
    Senior Member edutilos-'s Avatar
    Join Date
    Dec 2010
    Location
    The Universe
    Posts
    5,991

    Default Re: Help! what is this small white cross doing on my photos!

    Another link on this: http://www.slashgear.com/how-to-remo...l-slr-2227392/

    This one mentions that you should take off your lens when running that cool routine. Worth trying, I guess?

  19. #19
    Senior Member bonrya's Avatar
    Join Date
    Dec 2010
    Location
    In a mobile cage
    Posts
    2,632

    Default

    I get this problem sometimes but I find that the problem removes itself after I let the camera cool down/format the card. Dunno what's the problem TBH but you can try what I did.

    Usually get this after I do long exposure.
    My Flickr
    ~Neko baka

  20. #20

    Default Re: Help! what is this small white cross doing on my photos!

    Lately there seem to be a lot of these exact same issues on the newer Canon bodies (I see it on DPR as well). Is it maybe a flaw in the latest sensors? I don't see the same issues reported on the Nikon forums (which, sales-wise, are close to Canon)
    Alpha

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •