Results 1 to 8 of 8

Thread: regarding flash.

  1. #1

    Default regarding flash.

    Hi all, am new to this forums so would like to seek help but I have no idea where to start from.

    Ok basically I own a yashica ME1 film compact, along with a National PE-205 flash unit. The camera takes photos fine but the flash does not seem to be working.

    When I plug in the batteries (4AA) and turn it on, its possible to hear the "charging" sound but I didnt manage to get the flash working with the camera when attached via the hotshoe. there is this red button on the flash but when its pressed nth happens. anyone who have this flash or something similar could give me advice on how to get it working?

    Thanks

  2. #2
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,393

    Default Re: regarding flash.

    If you press the red button (pilot button) and nothing happens then it looks like the flash is gone. Using fresh batteries?
    EOS

  3. #3
    Moderator daredevil123's Avatar
    Join Date
    Oct 2005
    Location
    lil red dot
    Posts
    21,627
    Blog Entries
    1

    Default Re: regarding flash.

    Quote Originally Posted by Octarine View Post
    If you press the red button (pilot button) and nothing happens then it looks like the flash is gone. Using fresh batteries?
    Yup... might be a blown flash tube.

  4. #4

    Default Re: regarding flash.

    thanks guys, if its a blown flash tube anywhere can service in SG? or must get a new flash?

  5. #5
    Moderator daredevil123's Avatar
    Join Date
    Oct 2005
    Location
    lil red dot
    Posts
    21,627
    Blog Entries
    1

    Default Re: regarding flash.

    Quote Originally Posted by gtsfrost View Post
    thanks guys, if its a blown flash tube anywhere can service in SG? or must get a new flash?
    You can try camera hospital, camera consultant, or you can try bro fatigue.

  6. #6
    Member Ohitsujiz's Avatar
    Join Date
    Mar 2011
    Location
    Singapore
    Posts
    14

    Default Re: regarding flash.

    Guys am not sure but is it true by using a 3rd party flash will make your cam go out of sync ???

  7. #7
    Moderator Octarine's Avatar
    Join Date
    Jan 2008
    Location
    Pasir Ris
    Posts
    12,393

    Default Re: regarding flash.

    Quote Originally Posted by Ohitsujiz View Post
    Guys am not sure but is it true by using a 3rd party flash will make your cam go out of sync ???
    Where have you heard about this? In which context? Do note that there is normal flash synchronization (which should not be an issue, many cheap 3rd party [radio] triggers can do the job) and High Speed Sync. The latter one needs to be supported by the flash.
    EOS

  8. #8

    Default Re: regarding flash.

    thanks guys. went down to camera hospital, said that the circuit board might be corroded.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •