Results 1 to 4 of 4

Thread: Weird Dry-cabinet

  1. #1

    Question Weird Dry-cabinet

    Hello guys,

    I was wondering if any of you have had the same problem i face. I've had a digi-cabi analogue for a while but the RH doesnt go below 54% (set at 12o'clock) and the day before i turned it clockwise and the RH went up to 69% (set at 1 o'clock). yesterday, i decided to turn it anticlockwise ( to 11 o'clock) and RH became 80% and the green light went off (red light stayed). Looks like there's no pleasing the dry-cab.

    I wanted to achieve a RH of 50%. Am i doing it wrongly, but i turn both ways leh..
    Alpha
    Want to get back to photography

  2. #2
    Senior Member edutilos-'s Avatar
    Join Date
    Dec 2010
    Location
    The Universe
    Posts
    5,991

    Default

    Check your hygrometer with salt test. Google for this.

  3. #3
    Senior Member ZerocoolAstra's Avatar
    Join Date
    Mar 2008
    Location
    rainy Singapore
    Posts
    9,523

    Default

    I can think of 3 possibilities:

    1) faulty unit. Unable to remove enough moisture.

    2) leaking seals. Humid air from outside gets in. Unit cannot remove moisture fast enough.

    3) inaccurate hygrometer

    Hope you can solve the problem!
    Exploring! :)

  4. #4
    Member digisheep's Avatar
    Join Date
    Sep 2010
    Location
    Singapore
    Posts
    140

    Default Re: Weird Dry-cabinet

    Your dry cabinet's dehumidifier could be spoiled... Do send it for repair...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •