Page 2 of 2 FirstFirst 12
Results 21 to 23 of 23

Thread: Help needed! new camera, white pixels

  1. #21

    Default Re: Help needed! new camera, white pixels

    Quote Originally Posted by Etna-sama View Post
    Wah, new to photography and already started pixel-peeping.

    Of course, I understand you are concerned when the camera is barely a month old and still covered by warranty: after all, nobody wants to buy a brand-new product and deal with defects.

    That being said, i hope this pixel-peeping habbit of yours will go away after some time. In the end, a camera is merely a tool to take great pictures, and a handful of scattered dead pixels are unlikely to show themselves after you resize your images to usable dimensions. Unless you are into macro and night photography, that is.
    TS' camera did have hot pixel issues...
    Canon EOS 6D | 16-35mm f/2.8L II USM | 24-70mm f/2.8L USM | 50mm f/1.4 HSM | 70-200mm f/2.8L IS USM

  2. #22

    Default Re: Help needed! new camera, white pixels

    Quote Originally Posted by Rawbeansta View Post
    TS' camera did have hot pixel issues...
    I was being playful lah, no need to take it so seriously...

  3. #23

    Default Re: Help needed! new camera, white pixels

    glad the TS' problem was resolved.

    I'm wondering how long will it take for CSC to remap the hot pixel just in case. Does anyone know if it can be done the same day or one has to wait for a week or so?

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •