Results 1 to 4 of 4

Thread: Lens fungus

  1. #1
    Member
    Join Date
    Sep 2010
    Location
    North
    Posts
    250

    Default Lens fungus

    Hi guys,

    I have an old megazoom camera, and for the past few months there's been 'spots' appearing on its lens. I initially thought it was fungus but I've always thought fungus looks spidery, but the 'spots' in the lens don't look spidery at all.

    Does anyone happen to know what these spots could be? :/

  2. #2

    Default Re: Lens fungus

    ....dust?
    Alpha

  3. #3

    Default Re: Lens fungus

    Quote Originally Posted by stein View Post
    Hi guys,

    I have an old megazoom camera, and for the past few months there's been 'spots' appearing on its lens. I initially thought it was fungus but I've always thought fungus looks spidery, but the 'spots' in the lens don't look spidery at all.

    Does anyone happen to know what these spots could be? :/
    Dust or grease? any pictures?

  4. #4
    Moderator daredevil123's Avatar
    Join Date
    Oct 2005
    Location
    lil red dot
    Posts
    21,627
    Blog Entries
    1

    Default Re: Lens fungus

    Quote Originally Posted by stein View Post
    Hi guys,

    I have an old megazoom camera, and for the past few months there's been 'spots' appearing on its lens. I initially thought it was fungus but I've always thought fungus looks spidery, but the 'spots' in the lens don't look spidery at all.

    Does anyone happen to know what these spots could be? :/
    fungus got many kinds... some starts off as spots first.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •