Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Thread: Need help: SB600 Won't FIRE whatsoever

  1. #1

    Default Need help: SB600 Won't FIRE whatsoever

    Just bought it 2nd handed a while ago, worked perfectly until tonight.
    Now it just won't fire even with new batteries (both rechargeable and un-rechargeable)
    The LCD and every button still work normally though.

    I tried to reset by pressing the Mode + Power button, but it still not firing anymore.


    Can anyone tell me what should I do now please

  2. #2
    Moderator catchlights's Avatar
    Join Date
    Sep 2004
    Location
    Punggol, Singapore
    Posts
    21,902

    Default Re: Need help: SB600 Won't FIRE whatsoever

    just send it to Nikon Service Center to diagnose it.

    Nikon Singapore Pte Ltd
    [Service Centre]
    : No. 80 Anson Road, Fuji Xerox Towers, #10-01/02
    Singapore 079907

    Operating Hours :
    Mon, Tue, Fri: 9am - 530pm
    Wed and Thu: 9am - 7pm



    Hotline
    Fax

    : 6 5596 363
    : 6 5593 669
    Shoot to Live, Live to Shoot
    www.benjaminloo.com | iStock portfolio

  3. #3

    Default Re: Need help: SB600 Won't FIRE whatsoever

    You press the Flash/Fire button, you can hear a tick sound, and the flash LED flashes a wee bit? But then no light flash from the flash tube? If so the flash tube pai liao....

    These are HID technology. Over a certain usage sure spoil. Like flouroscent, which is low pressure mercury. But actually more like metal halide than low pressure mercury....

  4. #4
    Senior Member ZerocoolAstra's Avatar
    Join Date
    Mar 2008
    Location
    rainy Singapore
    Posts
    9,523

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Quote Originally Posted by IntoTheRainbow View Post
    Just bought it 2nd handed a while ago, worked perfectly until tonight.
    Now it just won't fire even with new batteries (both rechargeable and un-rechargeable)
    The LCD and every button still work normally though.

    I tried to reset by pressing the Mode + Power button, but it still not firing anymore.


    Can anyone tell me what should I do now please
    as '2100' suggested, try pressing the test flash button. Does it fire?
    If not, follow 'catchlights' suggestion: bring to NSC for diagnosis and probably repair.

    hope that helps
    Exploring! :)

  5. #5

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Quote Originally Posted by IntoTheRainbow View Post
    Just bought it 2nd handed a while ago, worked perfectly until tonight.
    Now it just won't fire even with new batteries (both rechargeable and un-rechargeable)
    The LCD and every button still work normally though.

    I tried to reset by pressing the Mode + Power button, but it still not firing anymore.


    Can anyone tell me what should I do now please

    samething happen to my sb600 last mth. most likely it's the pcb or flash tube. Nikon quote me 180, as i'm out of warranty so no point fixing. sell to fatigue bro instead lol.

    hope urs still under warranty.

  6. #6

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Yup just as 2100 has mention. The bulb is either burnt (most of the time) or the circuitry is faulty. Yes the bulb is cheap. but the servicing and replacement is around hundred plus...There is a website somewhere where you can replace it...quite delicate at some stage...All the best.

  7. #7

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Quote Originally Posted by 2100 View Post
    You press the Flash/Fire button, you can hear a tick sound, and the flash LED flashes a wee bit? But then no light flash from the flash tube? If so the flash tube pai liao....

    These are HID technology. Over a certain usage sure spoil. Like flouroscent, which is low pressure mercury. But actually more like metal halide than low pressure mercury....
    no it wont flash or sound anything
    the AF assist infrared even wont work


    I will bring to NSC and see what do they say

  8. #8

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Quote Originally Posted by IntoTheRainbow View Post
    no it wont flash or sound anything
    the AF assist infrared even wont work


    I will bring to NSC and see what do they say
    Good luck, hope just minor repair if needed. pls update to us the outcome.thks

  9. #9
    Senior Member fatigue's Avatar
    Join Date
    Sep 2005
    Location
    Blk138 Bedok North Ave3
    Posts
    2,924

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Quote Originally Posted by IntoTheRainbow View Post
    no it wont flash or sound anything
    the AF assist infrared even wont work


    I will bring to NSC and see what do they say
    How about the "READY" light? Does it light up?
    If this light is ON, there will be no sound since the capacitor is charged up.
    Possible problem is a busted tube. (usual cause of busted tube is due accidental drop of flash unit)

    If the "READY" light does not turn ON and no sound, possible problem is the charging PCB.
    Same as baggiolee's unit.
    9815-1974
    FB: Hilos Camera Repair

  10. #10

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Quote Originally Posted by fatigue View Post
    How about the "READY" light? Does it light up?
    If this light is ON, there will be no sound since the capacitor is charged up.
    Possible problem is a busted tube. (usual cause of busted tube is due accidental drop of flash unit)

    If the "READY" light does not turn ON and no sound, possible problem is the charging PCB.
    Same as baggiolee's unit.
    hmm the flash button light is on, but the Ready light is not

    Btw when I let the flash idle for a while, it will show BAT on the LCD panel. Which, i believe, indicates that there is some problem with the batteries, however I've tried 3 other kind of AA batteries, all resulted the same
    Last edited by IntoTheRainbow; 30th November 2010 at 01:25 PM.

  11. #11

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Quote Originally Posted by IntoTheRainbow View Post
    hmm the flash button light is on, but the Ready light is not

    Btw when I let the flash idle for a while, it will show BAT on the LCD panel. Which, i believe, indicates that there is some problem with the batteries, however I've tried 3 other kind of AA batteries, all resulted the same
    i'm quite sure they'll charge u the same as mine. unless they double standard...update us if possible.


  12. #12

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Quote Originally Posted by baggiolee View Post
    i'm quite sure they'll charge u the same as mine. unless they double standard...update us if possible.

    http://img181.imageshack.us/img181/8959/dsc0165r.jpg
    I'll be damned

    Btw how much did you sell urs btw?

  13. #13
    Senior Member fatigue's Avatar
    Join Date
    Sep 2005
    Location
    Blk138 Bedok North Ave3
    Posts
    2,924

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Quote Originally Posted by baggiolee View Post
    samething happen to my sb600 last mth. most likely it's the pcb or flash tube. Nikon quote me 180, as i'm out of warranty so no point fixing. sell to fatigue bro instead lol.

    hope urs still under warranty.
    Quote Originally Posted by IntoTheRainbow View Post
    I'll be damned

    Btw how much did you sell urs btw?
    Before it gets OT.
    I bought the defective SB600 for fun. Hoping to fix them someday.
    I already bought 4 defective units since last year
    Too busy with other peoples gears that I haven't touch any of my gears yet
    9815-1974
    FB: Hilos Camera Repair

  14. #14

    Default Re: Need help: SB600 Won't FIRE whatsoever

    i have the same problem of not firing usually when it fires off then u will hear a recharge sound but mine when it fires it juz gives me a tick sound. Mine's still under warrnaty so im unsure if they would charge me similar prices.. sigh!! what bad luck but i did not drop or temper the sb600 juz normal usage..
    D5000 | Nikkor AF-S 18-55 VR 3.5-5.6G | Nikkor AF-S 55-200 VR 4-5.6G | Nikkor AF-S 35mm F1.8 | SB600

  15. #15

    Default Re: Need help: SB600 Won't FIRE whatsoever

    When and where you bought it from?

    Return to the seller / shop..


  16. #16
    Senior Member fatigue's Avatar
    Join Date
    Sep 2005
    Location
    Blk138 Bedok North Ave3
    Posts
    2,924

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Quote Originally Posted by almighty00 View Post
    i have the same problem of not firing usually when it fires off then u will hear a recharge sound but mine when it fires it juz gives me a tick sound. Mine's still under warrnaty so im unsure if they would charge me similar prices.. sigh!! what bad luck but i did not drop or temper the sb600 juz normal usage..
    The problem could be a defective tube.
    You don't hear the recharge sound since the capacitor was not discharged.

    No need to worry since your flash still got warranty.
    Unless there's a sign of breakage on the tube, then the technician will know that the flash has been accidentally dropped.
    9815-1974
    FB: Hilos Camera Repair

  17. #17
    Senior Member Big Kahuna's Avatar
    Join Date
    Dec 2004
    Location
    Singapore, Singapore, Singapor
    Posts
    2,127

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Try a fresh set of rechargable battery, might be weak voltage...last time I use some old rechargable battery....and my SB600 became erratic....got a scare but problem resolved when I use Sanyo Eneloop

  18. #18

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Just back from the NSC, Nikon quoted me a total of 133$ for it. They will do 6 months warranty on the replaced part though, guess it's a fair one. I will take it back in probably 2 weeks.

  19. #19

    Default Re: Need help: SB600 Won't FIRE whatsoever

    hi i had the same problem in which the sb600 won't fire i brought it down to NSC got it back after one week they didn charge. Only comment on the service slip was flash tube replaced. So finally my sb600 is alive!
    D5000 | Nikkor AF-S 18-55 VR 3.5-5.6G | Nikkor AF-S 55-200 VR 4-5.6G | Nikkor AF-S 35mm F1.8 | SB600

  20. #20

    Default Re: Need help: SB600 Won't FIRE whatsoever

    Quote Originally Posted by almighty00 View Post
    hi i had the same problem in which the sb600 won't fire i brought it down to NSC got it back after one week they didn charge. Only comment on the service slip was flash tube replaced. So finally my sb600 is alive!
    really? but u got warranty right?
    they say they will replace the flash tube too. I dont have no warranty watsoever

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •