Results 1 to 13 of 13

Thread: Is anyone experiencing bad Internet speeds from Singnet?

  1. #1
    Member Cartman2000's Avatar
    Join Date
    Dec 2008
    Location
    Pasir Ris
    Posts
    1,732

    Default Is anyone experiencing bad Internet speeds from Singnet?

    I've noticed that my Internet connection has suffered greatly ever since the YOG commenced. Loading times for Facebook, Youtube, Twitter and the like have been rather unacceptable. The connection often resets and leaves me with no access to the Internet for brief peroids of about 20 seconds or so. Wonder if any other subscribers are experiencing similar issues

    I've called Singnet customer service and they directed me to do some network configurations, followed by a speed test. Results showed that performance was "up to their standards" and they would only send a technician if the speeds ever dipped below that mark.

    Could it be due to the YOG?
    Last edited by Cartman2000; 21st August 2010 at 11:04 PM.

  2. #2
    Member
    Join Date
    Dec 2004
    Location
    Sembawang
    Posts
    1,479

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    I also using singnet and seem normal to me.. don't really see a drop in speed during YOG...and if you did a speedtest on your connection and is within what you pay for, then I guess should be ok....

    I also sometimes encounter brief periods of disconnection...but this already occurs before YOG...maybe is your area only?
    Last edited by scramblur11; 21st August 2010 at 11:10 PM.

  3. #3
    Senior Member
    Join Date
    May 2004
    Location
    Sengkang
    Posts
    2,922

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    I live around Teban area and my SingNet speed is rather intermitent at times. Quite frustrating sometimes especially when I need to send important stuff over.

  4. #4
    Member Cartman2000's Avatar
    Join Date
    Dec 2008
    Location
    Pasir Ris
    Posts
    1,732

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    Quote Originally Posted by scramblur11 View Post
    I also using singnet and seem normal to me.. don't really see a drop in speed during YOG...and if you did a speedtest on your connection and is within what you pay for, then I guess should be ok....

    I also sometimes encounter brief periods of disconnection...but this already occurs before YOG...maybe is your area only?
    On paper, everything seems fine. The biggest difference has been when using Youtube. A decently popular 9 minute video used to buffer completely within 30 seconds. Now, it buffers as the video plays and sometimes even drops below that speed.

  5. #5
    Member Cartman2000's Avatar
    Join Date
    Dec 2008
    Location
    Pasir Ris
    Posts
    1,732

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    Quote Originally Posted by hazmee View Post
    I live around Teban area and my SingNet speed is rather intermitent at times. Quite frustrating sometimes especially when I need to send important stuff over.
    Trying to watch the Arsenal v Blackpool game over an online stream now. I have already missed 3 goals

  6. #6
    Senior Member +evenstar's Avatar
    Join Date
    Jan 2004
    Location
    Singapore / United Kingdom
    Posts
    5,655

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    Quote Originally Posted by Cartman2000 View Post
    Trying to watch the Arsenal v Blackpool game over an online stream now. I have already missed 3 goals
    it might be the host server?
    eat. drink. shoot

  7. #7

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    My internet connection seems normal.

  8. #8
    Member
    Join Date
    Dec 2006
    Location
    Singapore
    Posts
    990

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    Mine has been very intermittent since the broadband has band incorporated under Mio. It will just cut off internet connection periodically or slows so much to the point its worse than 56kb era. NEVER ever get or upgrade to Mio...

    My modem recently no connection to internet (i.e. modem's indicator for "internet" is red). Called singnet and a technician came over to reset and its ok now (ok as in the same as the intermittent past).
    Dun blame the camera...blame the one behind the viewfinder :bsmilie:
    My Flickr..pls leave comments!

  9. #9

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    before i upgraded to 3mb from 1mb plan, the speed was ok, watching videos from youtube weren't lag at up. now, it's like worst than 1mb...
    Objection !!!

  10. #10

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    i'm using MIO...

    technicians came 3-4 times in one year...

    now still having problems...

  11. #11
    Senior Member
    Join Date
    Feb 2005
    Location
    sing
    Posts
    3,353

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    No problems since day one.
    Singnet.
    DON'T use mio.

  12. #12
    Member
    Join Date
    Oct 2007
    Location
    Born in KK hospital
    Posts
    685

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    Quote Originally Posted by tkbonz View Post
    Mine has been very intermittent since the broadband has band incorporated under Mio. It will just cut off internet connection periodically or slows so much to the point its worse than 56kb era. NEVER ever get or upgrade to Mio...

    My modem recently no connection to internet (i.e. modem's indicator for "internet" is red). Called singnet and a technician came over to reset and its ok now (ok as in the same as the intermittent past).


    same here 56kb...although my plan should be 10mb plan. Dun dun ever get Singnet Mio!!

  13. #13

    Default Re: Is anyone experiencing bad Internet speeds from Singnet?

    Quote Originally Posted by Canto View Post
    same here 56kb...although my plan should be 10mb plan. Dun dun ever get Singnet Mio!!
    Their service cmi also lol. Not trying to flame them but if you don't demand for an experienced technician to come and fix the problem, they will just keep sending technicians who have no idea what the problem is, with each technician identifying all sorts of different problems and not doing anything to solve the problem for more than a couple of hours.

    I've had great experience before I switched to mio, their router is hopeless, obviously not modded well. Worst thing is they don't allow you to use other routers, or make it frustratingly difficult to configure other routers to work with their connection. I notice their router tends to dump all the bandwith to a single computer if it's downloading something (not necessarily torrents, any downloads seem to suck all the bandwith from the router, making it more of a modem than a router)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •