Results 1 to 11 of 11

Thread: nEED hELP for Flash 580exII

  1. #1
    Member skudcam's Avatar
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    18

    Exclamation nEED hELP for Flash 580exII

    Hi guys,

    Can anyone share your expertise..... When i on my flash, sometimes the function showed only TTL.... then ETTL.... The E missing.... Why the E missing??? Currently i am using canon 40D...

    is it becoz of the batteries; the connection; or....

    Thanx all for sharing....

  2. #2

    Default Re: nEED hELP for Flash 580exII

    Are you using Mark II of 580EX/430EX? If so, yes, high chance is a connection problem which unfortunately is common to many users and Canon does not have a proper fix to date.

  3. #3

    Default Re: nEED hELP for Flash 580exII

    Clean the contacts of both the flash and the hotshoe and try again.

  4. #4

    Default Re: nEED hELP for Flash 580exII

    Extremely irritating when that happens especially when 580EX II is so expensive already.
    5D MII w/16-35L,Sigma 28-70&Nikkors(35f2,85f1.4,105f2.5,180f2.8ED)

  5. #5

    Default Re: nEED hELP for Flash 580exII

    very likely connection issue.
    very likely wear and tear.
    Last edited by blurry80; 3rd March 2010 at 06:15 PM.
    5DMk2,400D,EOS3 50mm F1.4,28-75 F2.8,GRDIII 28mm F1.9
    www.flickr.com/jenson_goh

  6. #6

    Default Re: nEED hELP for Flash 580exII

    Extremely irritating when that happens especially when 580EX II is so expensive already.
    I know, right. Which is why there are some who are still sticking and specifically looking for the Mark I.

  7. #7
    Senior Member denniskee's Avatar
    Join Date
    Oct 2003
    Location
    bukit batok
    Posts
    5,468

    Default Re: nEED hELP for Flash 580exII

    if you type "580exll connection problem" to do google search,

    http://shimworld.wordpress.com/2008/...i-hotshoe-fix/
    photography makes one sees things from all angles.

  8. #8
    Senior Member
    Join Date
    Oct 2005
    Location
    1.45N 103.83E
    Posts
    3,202

    Default Re: nEED hELP for Flash 580exII

    I had this problem when I initially use my 580mk2. After reading a thread regarding a diy fix. Now I no longer have this problem. Have to open up the flash and tighten the mounting screws.

  9. #9

    Default Re: nEED hELP for Flash 580exII

    Why Canon does not acknowledge this problem? They should have announce and offer free fix like the 5d classic mirror problem

  10. #10

    Default Re: nEED hELP for Flash 580exII

    Quote Originally Posted by chalib View Post
    Why Canon does not acknowledge this problem? They should have announce and offer free fix like the 5d classic mirror problem
    If it can be DIY fixed or quietly fixed by Canon Service Centre when you hand it in then why not? Who wants a Toyota-style global recall? Whatever the problem you may encounter with your equipment, thank your lucky stars that you have CSC at your disposal. I only have access to a distributor in Brunei and a return drive there is 2.5 hours and they don't provide that level of support so I in my own isolation, I DIY a lot including Sensor and Viewfinder cleaning.
    JAN SHIM PHOTOGRAPHY
    www.shimworld.com

  11. #11

    Default Re: nEED hELP for Flash 580exII

    yeah..irritating...intermittent failures..

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •